UVA1025 A Spy in the Metro(dp)

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.
Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria.
The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.
Input
The input file contains several test cases. Each test case consists of seven lines with information as follows.
Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations.
Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment.
Line 3. N − 1 integers: t1, t2, … , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2 the time between the second and the third station, and so on.
Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first station.
Line 5. M1 integers: d1, d2, … , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which trains depart from the first station.
Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th station.
Line 7. M2 integers: e1, e2, … , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which trains depart from the N-th station.
The last case is followed by a line containing a single zero.
Output
For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.
Sample Input
4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
123
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17 0
Sample Output
Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

是暑假做的第一个dp,,一直很想这个题的博客,因为当时想了半天才弄明白为什么要这样做。
一般我想普通dp的思路是 这个状态 可以从哪些状态转移过来,于是用已经有的状态更新当前状态。
影响当前决策的因素有 当前所在车站 和 当前的时间。
而要求解的是等待时间。
于是就可以定义dp[i][j] 为 第i秒时,spy在第j个车站,[还需要]等待的时间。这样边界条件就是DP[T][n]=0;答案在dp[0][1]里。
那状态怎么转移呢?
显然,对于每个状态,一共有三种决策:
1.等待一秒:dp[i][j]=dp[i+1][j]+1;
2.此刻这个车站有向右开的车:dp[i][j]=dp[i+dis(j,j+1)][j+1];那这个状态就从第[i+dis[j,j+1]]秒时,在j+1这个车站 转移过来;
3.此刻有向左开的车:dp[i][j]=dp[i+dis(j,j-1)][j-1]; 本弱最开始就是觉得这里有点绕,,事实证明还是想多了,只是要考虑一个刷表顺序的问题。
把时间的循环 for T-1 downto 1 do 放在最外圈,所有t》i的状态都是已知的了。放心大胆的转移就是。。。。
dp=min(三种情况);

最后就是边界条件要处理好,dp[T][i=1;i《n-1]=maxn;时间到却无法到达N站,这样的结果并不是我们要的,不能有状态转移到这些结果上来,,,所以要用maxn 除去。

#include <stdio.h>
#include <string.h>
int r[2005][60],l[2005][60],tot[100],tot2[100],t[100],dp[250][60];
int main()
{
    int x,i,j,n,mr,ml,a,tt;
    //freopen("in.txt","r",stdin);
    x=0;
    while(~scanf("%d",&n)&&n!=0)
    {
        memset(tot,0,sizeof(tot));
        memset(tot2,0,sizeof(tot2));
        memset(dp,0,sizeof(dp));
        memset(t,0,sizeof(t));
        memset(r,0,sizeof(r));
        memset(l,0,sizeof(l));
        x++;
        scanf("%d",&tt);
        for(i=1;i<=n-1;i++)
        {
            scanf("%d",&t[i]);
            tot[i+1]=t[i]+tot[i];
        }
        for(i=n-1;i>=1;i--)
            tot2[i]=t[i]+tot2[i+1];
        scanf("%d",&mr);
        for(i=1;i<=mr;i++)
        {
            scanf("%d",&a);
            for(j=1;j<=n;j++)   
            {
                r[a+tot[j]][j]=1;

            }
        }
        scanf("%d",&ml);
        for(i=1;i<=ml;i++)
        {
            scanf("%d",&a);
            for(j=1;j<=n;j++)
            {
                l[a+tot2[j]][j]=1;
                //printf("%d ",a+tot2[j]);
            }
        }
        int maxn=100000000;
        for(i=1;i<=n-1;i++) dp[tt][i]=maxn;
            dp[tt][n]=0;
        for(i=tt-1;i>=0;i--)
            for(j=1;j<=n;j++)
            {
                dp[i][j]=dp[i+1][j]+1;
                if(j<n&&r[i][j]==1&&dp[i+t[j]][j+1]<dp[i][j]&&i+t[j]<=tt)
                    dp[i][j]=dp[i+t[j]][j+1];
                if(1<j&&l[i][j]==1&&dp[i+t[j-1]][j-1]<dp[i][j]&&i+t[j-1]<=tt)
                    dp[i][j]=dp[i+t[j-1]][j-1];

            }
        printf("Case Number %d: ",x);   
        if(dp[0][1]>=maxn) printf("impossible\n");
        else printf("%d\n",dp[0][1]);
    }
    return 0;

}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值