SOJ Dollars 解题报告

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 tex2html_wrap_inline25 20c, 2tex2html_wrap_inline25 10c, 10c+2 tex2html_wrap_inline25 5c, and 4 tex2html_wrap_inline25 5c.

Input

Input will consist of a series of real numbers no greater than $50.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 5), followed by the number of ways in which that amount may be made up, right justified in a field of width 12.

Sample input

0.20
  2.00
0.00

Sample output

 0.20           4
 2.00         293
刚开始拿到这道题时,想到的是老师课堂上讲过的整数划分问题 所以就尝试着用递归的方法去解决,但是在跑出来的结果会莫名的少了一些划分情况,在加断点调试了之后才发现是小数相减之后的精度问题导致一些情况没有被累加到,通过神奇地度娘知道了用BigDecimal来解决 一下便是我的代码
package acm;
import java.util.*;
import java.math.BigDecimal;


public class Dollars{ 
	static double[] money=new double[]{100,50,20,10,5,2,1,0.5,0.2,0.1,0.05};
	static int d(double n,int i){
		BigDecimal a1 = new BigDecimal(Double.toString(money[i]));
		BigDecimal b1 = new BigDecimal(Double.toString(n));
 		if(money[i]==0.05 || n==0.05) return 1;
		if( i>10 || n<0.05) return 0;
		if(n==money[i]) return 1+d(n,i+1);
 		if(money[i]>n){
 		while(money[i]>n) i++;
			return d(n,i);
		}
  		else return d(b1.subtract(a1).doubleValue(),i)+d(n,i+1);
		
	}
    public static void main(String args[]){
        Scanner input = new Scanner(System.in);
        double m = input.nextDouble();
        while(m!=0.0){
        	System.out.printf("%5.2f%12d\n",m,d(m,0));
        	m=input.nextDouble();
        }
        input.close();
        }
    }
但是 新的问题又来了 用递归调用测小数据时还好,当测试到50时,竟然好久答案还没出来 递归的效率太低在OJ上提交时也出现时TLE的问题,所以和同学交流及搜索网上资料后 采用递推的方法解决
package acm;
import java.util.*;
//import java.math.BigDecimal;


public class Dollars{ 
	
    public static void main(String args[]){
    	int[] money = new int[]{1,2,4,10,20,40,100,200,400,1000,2000};
    	int[] ans = new int[6001]; 
    	Scanner input = new Scanner(System.in);
        float m = input.nextFloat();
    	ans[0]=1;
    	for(int i=0;i<11;i++){
    		for(int j=money[i];j<6001;j++){
    			ans[j]+=ans[j-money[i]];
    		}
    	}
       
        while(m!=0.0){
        	System.out.printf("%5.2f%12d\n",m,ans[(int)(m/0.05)]);
        	m=input.nextFloat();
        }
        input.close();
        }
    }
终于都Accepted了 不过有点无语的是不知为什么是double型的时候一直WRO 一改成float就过了 还是要多多累计经验。

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值