hdoj5430Reflect【欧拉函数】

Reflect

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 445    Accepted Submission(s): 270


Problem Description
We send a light from one point on a mirror material circle,it reflects  N  times and return the original point firstly.Your task is calcuate the number of schemes.


 

Input
First line contains a single integer  T(T10)  which denotes the number of test cases. 

For each test case, there is an positive integer  N(N106) .
 

Output
For each case, output the answer.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
4
 

Source


既约分数即最简分数

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
int Euler(int n){
	int ret=1,i;
	for(i=2;i*i<=n;++i){
		if(n%i==0){
			n/=i;ret*=i-1;
			while(n%i==0){
				n/=i;ret*=i;
			}
		}
	}
	if(n>1)ret*=n-1;
	return ret;
}
int main()
{
	int t,i,j,k,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		printf("%d\n",Euler(n+1));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值