(dfs)Anagrams by Stack

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

iiiiooooioiiooio


where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.
Input
The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.
Output
For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by



and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Sample Input
madam
adamm
bahama
bahama
long
short
eric
rice
Sample Output
[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]



这道题有必要说一下,我就呵呵了,一看就有思路,敲的过程中各种错,只能说太笨了,不能一下想出具体的每个步骤怎么实现,不过有一个我感觉应该怪出题的,最后一个‘o’输出后还有一个空格,也是很醉人。

一开始提交我用的栈替换stack1数组,然后超时了,我以为和stl的时间复杂度有关,然后换成了数组还超时,然后我想到去掉没必要继续搜索的,然后就行了。

代码如下

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
string s;
string s2;
int l;
char stack1[200];
int judge(string node)
{
    int len=node.length();
    for(int i=0;i<len;++i)
        if(node[i]!=s2[i])
            return 1;
    return 0;
}
void print(string node)
{
    int len=node.length();
    for(int i=1;i<len;++i)
        cout<<node[i];
    cout<<" "<<endl;
}
void dfs(string stack2,string node,int dir,int k)
{

        if(dir<l)
        {
            if(judge(stack2))
                return ;
            stack1[k++]=s[dir];
            dfs(stack2,node+" i",dir+1,k);
            --k;
            if(k)
            {
                char ts=stack1[k-1];
                --k;
                dfs(stack2+ts,node+" o",dir,k);
                stack1[k++]=ts;
            }
        }
        else
        {
            if(judge(stack2))
                return ;
            if(stack2==s2)
            {

                    print(node);
                    return ;
            }
            if(k)
            {
                char ts=stack1[k-1];
                --k;
                dfs(stack2+ts,node+" o",dir,k);
                stack1[k++]=ts;
            }
            if(!k)
                {
                    return ;
                }
        }
}
int main()
{
    while(cin>>s>>s2)
    {
        if(s.length()==s2.length())
        {
            string node="";
            string stack2="";
            cout<<"["<<endl;
            stack1[0]='\0';
            l=s.length();
            dfs(stack2,node,0,0);
            cout<<"]"<<endl;
        }
        else
        {
            cout<<"["<<endl<<"]"<<endl;
        }
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值