poj2527——Polynomial Remains(多项式相除)

Description

Given the polynomial 
a(x) = a n x n + ... + a 1 x + a 0,

compute the remainder r(x) when a(x) is divided by x k+1.

Input

The input consists of a number of cases. The first line of each case specifies the two integers n and k (0 <= n, k <= 10000). The next n+1 integers give the coefficients of a(x), starting from a0 and ending with an. The input is terminated if n = k = -1.

Output

For each case, output the coefficients of the remainder on one line, starting from the constant coefficient r0. If the remainder is 0, print only the constant coefficient. Otherwise, print only the first d+1 coefficients for a remainder of degree d. Separate the coefficients by a single space. 

You may assume that the coefficients of the remainder can be represented by 32-bit integers. 

Sample Input

5 2
6 3 3 2 0 1
5 2
0 0 3 2 0 1
4 1
1 4 1 1 1
6 3
2 3 -3 4 1 0 1
1 0
5 1
0 0
7
3 5
1 2 3 4
-1 -1

Sample Output

3 2
-3 -1
-2
-1 2 -3
0
0
1 2 3 4

多项式相除,由于除数为x^k+1,因此商的当前项为anx^(n-k),使得余数多项式数组中的a[n]=0,a[n-k]=a[n-k]-a[n];然后调整a数组的长度

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
using namespace std;
int a[10010],n;    //a保存多项式以及改变之后的多项式
int main()
{
    int k,i;
    scanf("%d%d",&n,&k);
    while(n!=-1&&k!=-1)
    {
        for(i=0; i<=n; ++i)
            scanf("%d",&a[i]);
        for(i=n; i>=k; i--)
        {
            if(a[i]==0)
                continue;
            a[i-k]=a[i-k]-a[i];
            a[i]=0;
        }
        int t=n;
        while(a[t]==0&&t>0)  //调整多项式数组长度,直到最高项的不为0
            t--;
        for(i=0; i<t; ++i)
            if(a[i]!=0)
                printf("%d ",a[i]);
        printf("%d\n",a[t]);
        scanf("%d%d",&n,&k);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值