关闭

E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

3960人阅读 评论(0) 收藏 举报
分类:

安装terminator等一些软件等时候,遇到了这样等问题

复制代码
leo@leo:~$ sudo apt-get install terminator
[sudo] password for leo: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 terminator : 依赖: python-support (>= 0.90.0) 但是它将不会被安装
              依赖: python-vte 但是它将不会被安装
              推荐: python-gnome2 但是它将不会被安装
              推荐: python-keybinder 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
复制代码
复制代码
leo@leo:~$ sudo apt-get install vim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 vim : 依赖: vim-common (= 2:7.2.330-1ubuntu3.1) 但是 2:7.3.547-6ubuntu5 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
复制代码
复制代码
leo@leo:~$ sudo apt-get install g++
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 g++ : 依赖: g++-4.4 (>= 4.4.3-1) 但是它将不会被安装
       依赖: gcc-4.4 (>= 4.4.3-1) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
复制代码

 

于是百度了一下,发现是源的问题

解决办法:

打开更新设置,在“更新”选项卡中选则:重要安全更新 和 推荐更新

并在“其他软件”选项卡中,去掉有问题等源

最后在命令行里输入

sudo apt-get update

更新一下即可

 

这之后进行安装都不会有类似问题了


转载自:http://www.cnblogs.com/LeoGodfrey/p/3316834.html

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:90239次
    • 积分:1572
    • 等级:
    • 排名:千里之外
    • 原创:60篇
    • 转载:59篇
    • 译文:0篇
    • 评论:3条
    最新评论