uva 437 The Tower of Babylon (DAG)

uva 437 The Tower of Babylon

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions tex2html_wrap_inline32 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values tex2html_wrap_inline40 , tex2html_wrap_inline42 and tex2html_wrap_inline44 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Casecase: maximum height =height”

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:给出n种方块的长宽高,在满足上小下大(下面的方块的长款要分别大于上面的方块)的基础上,求最大高度。
解题思路:同一种方块改变接触面也可以叠在一起。读入数据的时候,将一个方块分成3个矩形。
例如:1 2 3这个方块可以分成
1)长:2,宽:1,值:3
1)长:3,宽:1,值:2
1)长:3,宽:2,值:1
三种矩形。然后就是DAG嵌套问题了。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#define N 100
using namespace std;
typedef long long ll;
int n;
struct block{
    int a, b, h;
};
block B[N * 3];
ll dp[N], Max;
int check(int x, int y) {
    if (B[x].a > B[y].a && B[x].b > B[y].b) return 1;
    if (B[x].a > B[y].b && B[x].b > B[y].a) return 1;
    return 0;
}
ll DP(int x) {
    if (dp[x]) return dp[x];
    for (int i = 0; i < 3 * n; i++) {
        if (check(i, x)) {
            ll temp = DP(i);
            if (temp > dp[x]) {
                dp[x] = temp;
            }
        }
    }
    dp[x] += B[x].h;
    return dp[x];
}
int main() {
    int Case = 1;
    while (scanf("%d", &n), n) {
        memset(dp, 0, sizeof(dp));
        memset(B, 0, sizeof(B));
        int a, b, c, cnt = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d %d %d", &a, &b, &c);
            B[cnt].a = a, B[cnt].b = b, B[cnt++].h = c;
            B[cnt].a = a, B[cnt].b = c, B[cnt++].h = b;
            B[cnt].a = b, B[cnt].b = c, B[cnt++].h = a;
        }
        Max = 0;
        for (int i = 0; i < n * 3; i++) {
            if (DP(i) > Max) {
                Max = DP(i);
            }
        }
        printf("Case %d: maximum height = %lld\n", Case++, Max);
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值