POJ 1704(Georgia and Bob-Nim博弈)

Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6341 Accepted: 1826

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source


先将数一一配对(a,b),若是奇数则把最左边与0配对。

那么若对方向左挪a,我们也挪动b相同步数。

那么唯一会影响的就是各配对间的间隔。

假设有间隔c1,c2..cn

那么相当于每次选一个数,减去至少1.

这就像nim取石,有n堆石子,每次至少取走其中一堆的至少一个,谁最先没石子取就输。

这个问题的答案是 c1^c2^..^cn=0时有必解,否则必胜。

都懂得……

证明:

假设你面对一个c1^c2^...^cn=0的局面

A:取走若干石子使c1^c2^...^cn=k

B:取走ci的最高位与k的最高位相同的那堆 ci^k个 //最高位的1^1=0,所以ci^k<ci 

A:恭喜你还是必输

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
int T,n,a[100000+10];
int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d",&n);
        For(i,n) scanf("%d",&a[i]);
        sort(a+1,a+1+n);
        int tmp=0,head=1;
        if (n%2) tmp=a[1]-1,head++;
        for(int i=head;i<=n;i+=2)
        {
            tmp^=(a[i+1]-a[i]-1);
        }
        if (tmp) puts("Georgia will win");
        else puts("Bob will win");
    }
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值