A - Can you find it?解题报告

A - Can you find it?
Time Limit:3000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input

       
       
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output

       
       
Case 1: NO YES NO
 

这个题目的意思呢就是从三组数中分别拉一个数出来,如果和==X的话就输出“YES”,否则输出“NO”;一开始虽然知道用硬的来时会超时,可是还是抱有侥幸的心态,结果TLE;还是用二分吧。这个二分首先将两个数组的和加起来,就是先开一个250001的数组,然后sort排序,然后呢就查找咯;
看代码把:

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int a[501],b[501],c[501],d[250001],L,N,M,k=0,i,j,qq=1,n,S;
	while(cin>>L>>N>>M)
	{
		k=0;
		for(i=0;i<L;i++)
			cin>>a[i];
		for(i=0;i<N;i++)
			cin>>b[i];
		for(i=0;i<M;i++)
			cin>>c[i];
		for(i=0;i<L;i++)
			for(j=0;j<N;j++)
				d[k++]=a[i]+b[j];
			sort(d,d+k);
			cin>>n;
			cout<<"Case "<<qq<<':'<<endl;
			for(i=0;i<n;i++)
			{
				cin>>S;
				for(j=0;j<M;j++)
				{
					int temp=S-c[j];
					int left=0,right=k-1,mid;
					while(left<right)
					{
						mid=(left+right)/2;
						if(d[mid]==temp)
						{
						cout<<"YES"<<endl;
							goto end;
						}
						else if(temp>d[mid])
						{
							left=mid+1;
						}
						else
						{
							right=mid;
						}
					}
				}
				cout<<"NO"<<endl;
end:;
			}
			qq++;
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值