HDU 1690 Bus System 任意点最短路径Floyd

原题: http://acm.hdu.edu.cn/showproblem.php?pid=1690

题目:

Bus System

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7648 Accepted Submission(s): 1984

Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

Sample Input
2
1 2 3 4 1 3 5 7
4 2
1
2
3
4
1 4
4 1
1 2 3 4 1 3 5 7
4 1
1
2
3
10
1 4

Sample Output
Case 1:
The minimum cost between station 1 and station 4 is 3.
The minimum cost between station 4 and station 1 is 3.
Case 2:
Station 1 and station 4 are not attainable.

思路:

图中的表是代表不同长度路径的花费,输入所有点的坐标,求任意两点间的最短花费。

因为是求任意两点,这里最好是用floyd算法。
题中几大坑:
数据可能会超int,要用long long int;
坐标可以为负,求距离要用abs绝对值函数。

代码:

#include <iostream>
#include"iostream"
#include"string.h"
#include"stdlib.h"
#include"stdio.h"
#include"math.h"
#define INF 0x3f7f7f7f7f7f7f7f
using namespace std;

typedef long long int lint;
const lint N = 105;
lint maze[N][N];
lint polint[N];
lint l1,l2,l3,l4,c1,c2,c3,c4;
lint n,m;
void init()
{
    for(lint i=0;i<N;i++)
    {
        for(lint j=0;j<N;j++)
        {
            maze[i][j]=INF;
        }
    }
}

lint getlen(lint x)
{
    if(x<=l1)    return c1;
    else if(x>l1&&x<=l2)    return c2;
    else if(x>l2&&x<=l3)    return c3;
    else if(x>l3&&x<=l4)    return c4;
    else    return INF;
}

void floyd()
{
    for(lint k=1;k<=n;k++)
    {
        for(lint i=1;i<=n;i++)
        {
            for(lint j=1;j<=n;j++)
            {
                maze[i][j]=min(maze[i][j],maze[i][k]+maze[k][j]);
            }
        }
    }
}

int main()
{
    lint cases;
    scanf("%I64d",&cases);
    for(lint k=1;k<=cases;k++)
    {
        scanf("%I64d %I64d %I64d %I64d %I64d %I64d %I64d %I64d",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4);
        scanf("%I64d %I64d",&n,&m);
        for(lint i=1;i<=n;i++)
        {
            scanf("%I64d",&polint[i]);
        }
        init();
        for(lint i=1;i<=n;i++)
        {
            for(lint j=i+1;j<=n;j++)
            {
                lint len=getlen(abs(polint[j]-polint[i]));
                maze[i][j]=len;
                maze[j][i]=len;
            }
        }
        floyd();
        printf("Case %I64d:\n",k);
        for(lint i=1;i<=m;i++)
        {
            lint x,y;
            scanf("%I64d %I64d",&x,&y);
            if(maze[x][y]!=INF)
                printf("The minimum cost between station %I64d and station %I64d is %I64d.\n",x,y,maze[x][y]);
            else
                printf("Station %I64d and station %I64d are not attainable.\n",x,y);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值