poj3104 Drying(二分)

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2

2

也是二分题。。。不要模拟。。不要贪心。。否则会WA掉的。。。。

用二分枚举时间的方法。。

说几个注意的地方。。

1 可能会爆int,所以要用 long long

2在每次烘干时,自然风干是没有的

3 当k为1的情况,独自考虑

4整数运算中,a/b的上取整可以用(a+b-1)/b。

贴代码。。。

#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
#define up(i,x,y) for(i=x;i<=y;i++)  
#define ll long long  
int n;  
int a[100005],k,ans,r,maxn,l,mid;  
  
int solve(int x)  
{  
    int i,sum=0;  
    up(i,0,n-1)  
    {  
        if(a[i]>x)  
        {  
            sum+=(a[i]-x+k-2)/(k-1);  
            if(sum>x) return 0;  
        }  
    }  
    return 1;  
}  
int main()  
{  
    int i,j;  
    while(~scanf("%d",&n))  
    {  
        maxn=0;  
        up(i,0,n-1)  
        scanf("%d",&a[i]);  
        sort(a,a+n);  
        scanf("%d",&k);  
        if(k==1)  
        {  
            printf("%d\n",a[n-1]);  
            continue;  
        }  
        l=1,r=a[n-1];  
        while(l<=r)  
        {  
            mid=l+(r-l)/2;  
            if(solve(mid))  
            {  
                ans=mid;  
                r=mid-1;  
            }  
            else  
                l=mid+1;  
  
        }  
        printf("%d\n",ans);  
    }  
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值