Prime Ring Problem(判断素数的几种方法)

判断素数的几种方法请参考这篇文章:

点击打开链接http://blog.csdn.net/qq_21120027/article/details/51107918

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Input
n (0 < n < 20). 
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<cstdio>
#include<string.h>
void isPrime(int a);
void dfs(int cur);
void show();
bool prime[45];
bool book[25];
int an[25];
int n;
int main()
{	
	int cnt;
	cnt=0;
	while(scanf("%d",&n)!=EOF)
	{
		memset(prime,true,sizeof(prime));
		memset(book,true,sizeof(book));
		memset(an,0,sizeof(an));
		an[0]=1;
		isPrime(2*n);
		printf("Case %d:\n",++cnt);
		dfs(1);		
		putchar('\n');
	}
	return 0;
}
void isPrime(int a)
{
	int i,j;
	for(i=2;i<a;i++)
	{
		for(j=i*i;j<a;j+=i)
			prime[j]=false;
	}
}
void dfs(int cur)
{
	if(cur==n)
	{
		if(prime[1+an[n-1]])
			show();
		return ;
	}
	for(int j=2;j<=n;j++)
	{
		if(book[j]&&prime[an[cur-1]+j])
		{
			an[cur]=j;
			book[j]=false;
			dfs(cur+1);
			book[j]=true;
		}
	}		
}
void show()
{
	int i;
	for(i=0;i<n-1;i++)
		printf("%d ",an[i]);
	printf("%d\n",an[n-1]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值