HDU 2588 GCD 欧拉函数

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1089    Accepted Submission(s): 498


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260
/*
HDOJ 2588 欧拉函数
给定N,M(2<=N<=1000000000, 1<=M<=N), 求1<=X<=N 且gcd(X,N)>=M的个数。

先找出N的约数x,并且gcd(x,N)>= M,结果为所有N/x的欧拉函数之和。

因为x是N的约数,所以gcd(x,N)=x>= M;
设y=N/x,y的欧拉函数为小于y且与y互质的数的个数。
设与y互质的的数为p1,p2,p3,…,p4, 
则:  x<x* pi<N, 满足1<=X<=N; 
那么gcd(x* pi,N)=x>= M。pi是与y质数 
*/
#include<iostream>
#include<stdio.h>
using namespace std;

int phi(int x)
{
	int i,ans=x;
	for(i=2;i*i<=x;i++)
	{
		if(x%i==0)
		{
			ans-=ans/i;
			while(x%i==0)
			{
				x=x/i;
			}
		}
	}
	if(x>1)
		ans-=ans/x;
	return ans;
}
int solve(int n,int m)
{
	int i,sum=0;
	for(i=1;i*i<=n;i++)
	{
		if(n%i!=0)
			continue;
		if(i>=m&&i*i!=n)//当i=nn时,n/i=nn,要避免求了两次欧拉函数
			sum+=phi(n/i);
		if(n/i>=m)		//对称的
			sum+=phi(i);
	}
	return sum;
}
int main()
{
	int n,m,t;
	//freopen("test.txt","r",stdin);
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		printf("%d\n",solve(n,m));
	}
	 
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值