HDU 5952 Counting Cliques 暴力搜索

题目描述:

Problem Description
A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph.

Input
The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

Output
For each test case, output the number of cliques with size S in the graph.

Sample Input

3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6

Sample Output

3
7
15

Source
2016ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

题目分析:

一个n个点,m条边的无向图中,求n个点的完全子图的数量。

只需要暴力搜索每一个点,将可能成为s元完全子图的点(这个点相连的所有点)也加入,同时更新这个完全子图中的点数和那些点,搜索到完全子图中点数为s返回。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <string>
#include <vector>
#include <set>

using namespace std;

const int MAXN=110;
vector<int> G[MAXN];
int mp[MAXN][MAXN];
int n,m,s;
int T;
int ans;

void dfs(int u,int * tmp, int size)
{
    if (size==s)
    {
        ans++;
        return;
    }
    bool f;
    for(int i=0; i<G[u].size(); i++)//可能加入团的点
    {
        int v=G[u][i];
        f=true;
        for(int j=1; j<=size; j++)//遍历团中所有点,判断是否与将要加入的点相连
        {
            if (!mp[v][tmp[j]])
            {
                f=false;
                break;
            }
        }
        if (f)//这个点可以加入团,加入并继续深搜
        {
            size++;
            tmp[size]=v;
            dfs(v,tmp,size);
            tmp[size]=0;
            size--;
        }
    }
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&s);
        for(int i=1; i<=n; i++) G[i].clear();
        memset(mp,0,sizeof(mp));
        ans=0;
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            if (u>v) swap(u,v);
            G[u].push_back(v);
            mp[u][v]=mp[v][u]=1;
        }
        for(int i=1; i<=n; i++)
        {
            int size=1;//团的规模
            int tmp[MAXN];//tmp集合表示这个团中有哪些点 
            tmp[1]=i;
            dfs(i,tmp,size);
        }
        printf("%d\n",ans);
    }
    return 0;
}
/*
3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6
*/
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值