hdu1728 逃离迷宫 【bfs记录转向次数 2种】

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19646    Accepted Submission(s): 4779


Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
  
  
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output
  
  
no yes
 
呃,其实呢,这是上周的题了,因为知道了两种方法,但其中一种今天才搞明白就一直滞留到现在才发
第一种,就平常的思想,我用方向的i值比较记录转向数,但走过的点并非不能走了,若之前走的转向数大于等于当前转向数还是可以走的,不然会WA
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
char map[110][110];
int mark[110][110];
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int t,m,n,k,sx,sy,ex,ey;
struct node
{
    int x,y,f,cnt;
    friend bool operator < (node a,node b)
    {
        return a.cnt > b.cnt;
    }
};
int judge(int x,int y,int cnt)
{
    if(x<=0||x>m||y<=0||y>n)
        return 0;
    if(map[x][y]=='*')
        return 0;
    if(cnt>k)
        return 0;
    return 1;
}
void bfs()
{
    node ss,now,next;
    ss.x=sx;
    ss.y=sy;
    ss.f=-1;
    ss.cnt=0;
    mark[sx][sy]=1;
    priority_queue<node>q;
    q.push(ss);
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.x==ex&&now.y==ey&&now.cnt<=k)
        {
            printf("yes\n");
            return ;
        }
        for(int i=0;i<4;++i)
        {
            next.x=now.x+dir[i][0];
            next.y=now.y+dir[i][1];
            next.f=i;
            if(next.f!=now.f&&now.f!=-1)
                next.cnt=now.cnt+1;
            else 
                next.cnt=now.cnt;
            if(judge(next.x,next.y,next.cnt)&&(!mark[next.x][next.y]||mark[next.x][next.y]>=next.cnt))就是这里
            {
                mark[next.x][next.y]=next.cnt;
                q.push(next);
            }
        }
    }
    printf("no\n");
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(mark,0,sizeof(mark));
        scanf("%d%d",&m,&n);
        for(int i=1;i<=m;++i)
        {
            getchar();
            for(int j=1;j<=n;++j)
                scanf("%c",&map[i][j]);
        }
        scanf("%d%d%d%d%d",&k,&sy,&sx,&ey,&ex);
        bfs();
    }
    return 0;
}
 
第二种就是老大博客里的那种思想,就一直朝一个方向走知道不能走在转向,要注意,并非该方向上一点标记走过则该方向就不走了,而是该方向上一点标记走过之后,该点不再继续搜索而是走该方向上下一点,上星期在这WA了几次几天才懂
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int t,r,c,k,sx,sy,ex,ey;
char mazz[110][110];
int rec[110][110];
int dir[4][2]={0,1,0,-1,1,0,-1,0};
struct node
{
    int x,y,cnt;
};
int judge(int x,int y)
{
    if(x<1||x>r||y<1||y>c)
        return 0;
    if(mazz[x][y]=='*')
        return 0;
    return 1;
}
void bfs()
{
    node st,ed;
    st.x=sx;
    st.y=sy;
    st.cnt=-1;
    rec[sx][sy]=1;
    queue<node>q;
    q.push(st);
    while(!q.empty())
    {
        ed=q.front();
        q.pop();
        if(ed.x==ex&&ed.y==ey&&ed.cnt<=k)
        {
            printf("yes\n");
            return ;
        }
        if(ed.cnt>=k)
            continue;
        for(int i=0;i<4;++i)
        {
            st.x=ed.x+dir[i][0];
            st.y=ed.y+dir[i][1];
            st.cnt=ed.cnt+1;
            while(1)
            {
                if(judge(st.x,st.y))
                {
                    if(rec[st.x][st.y]==0)//若把这个判断是否走过放到judge函数里在while判断就会WA,但其他判断条件不符合则可直接跳出
                    {
                        rec[st.x][st.y]=1;
                        q.push(st);
                    }
                }
                else
                    break;
                st.x+=dir[i][0];
                st.y+=dir[i][1];
            }
        }
    }
    printf("no\n");
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(rec,0,sizeof(rec));
        scanf("%d%d",&r,&c);
        for(int i=1;i<=r;++i)
        {
            getchar();
            for(int j=1;j<=c;++j)
                scanf("%c",&mazz[i][j]);
        }
        scanf("%d%d%d%d%d",&k,&sy,&sx,&ey,&ex);
        bfs();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值