判决素数个数

判决素数个数

题目描述

X X X Y Y Y 之间的素数个数(包括 X X X Y Y Y)。

输入格式

两个整数 X X X Y Y Y 1 ≤ X , Y ≤ 1.1 × 1 0 6 1 \le X,Y \le 1.1 \times 10^6 1X,Y1.1×106)。

输出格式

输出一个整数,表示 X , Y X, Y X,Y 之间的素数个数(包括 X X X Y Y Y)。

样例 #1

样例输入 #1

1 100

样例输出 #1

25

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;
const ll N=11e5;
ll pri[N],cnt;
bool vis[N];

int main()
{
    ll x,y;
    cin>>x>>y;
    if(x>y) swap(x,y);

    for(ll i=2;i<=y;i++)
    {
        if(!vis[i]) pri[cnt++]=i;
        for(ll j=0;pri[j]*i<=y;j++)
        {
            vis[pri[j]*i]=1;
            if(i%pri[j]==0) break;
        }
    }
    ll ans=upper_bound(pri,pri+cnt,y)-lower_bound(pri,pri+cnt,x);

    cout<<ans<<endl;
    return 0;
}
  • 11
    点赞
  • 13
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值