hi.Team

Team

题面翻译

题目要求

三位选手要去参加编程竞赛,比赛共有N道题目,他们商定: 对于每一道题目,只有两位及以上的选手确认找到解法时才做。
试问,他们一共能做多少题?

输入格式

第一行一个整数N,表示题目的数量。
第二行到第N+1行,每行三个整数(0或者1),其中0表示这位选手无法解出此题,1表示这位选手想到了解法。

输出格式

一行,一个整数,表示他们所能做的题目的数量。

感谢@PC_DOS 提供翻译

题目描述

One day three best friends Petya, Vasya and Tonya decided to form a team and take part in programming contests. Participants are usually offered several problems during programming contests. Long before the start the friends decided that they will implement a problem if at least two of them are sure about the solution. Otherwise, the friends won’t write the problem’s solution.

This contest offers $ n $ problems to the participants. For each problem we know, which friend is sure about the solution. Help the friends find the number of problems for which they will write a solution.

输入格式

The first input line contains a single integer $ n $ ( $ 1<=n<=1000 $ ) — the number of problems in the contest. Then $ n $ lines contain three integers each, each integer is either $ 0 $ or $ 1 $ . If the first number in the line equals $ 1 $ , then Petya is sure about the problem’s solution, otherwise he isn’t sure. The second number shows Vasya’s view on the solution, the third number shows Tonya’s view. The numbers on the lines are separated by spaces.

输出格式

Print a single integer — the number of problems the friends will implement on the contest.

样例 #1

样例输入 #1

3
1 1 0
1 1 1
1 0 0

样例输出 #1

2

样例 #2

样例输入 #2

2
1 0 0
0 1 1

样例输出 #2

1

提示说明

In the first sample Petya and Vasya are sure that they know how to solve the first problem and all three of them know how to solve the second problem. That means that they will write solutions for these problems. Only Petya is sure about the solution for the third problem, but that isn’t enough, so the friends won’t take it.

In the second sample the friends will only implement the second problem, as Vasya and Tonya are sure about the solution.

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

int main()
{
    ll n;
    cin>>n;

    ll sum=0;
    while(n--)
    {
        ll y=3,op=0;
        while(y--)
        {
            ll x;
            cin>>x;
            if(x) op++;
        }

        if(op>=2) sum++;
    }

    cout<<sum<<endl;
    return 0;
}
  • 6
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值