Bit++

Bit++

题面翻译

有一种语言叫Bit++语言,只有一个变量 X X X ,初始为 0 0 0

有一个 n n n 行的Bit++语言的程序,每行只有一条语句,为X++,++X,X--,--X中的一种。其中X++,++X表示把 X X X 1 1 1X--,--X表示把 X X X 1 1 1

输出最终 X X X 的值。

感谢@rill7747 提供的翻译

题目描述

The classic programming language of Bitland is Bit++. This language is so peculiar and complicated.

The language is that peculiar as it has exactly one variable, called $ x $ . Also, there are two operations:

  • Operation ++ increases the value of variable $ x $ by 1.
  • Operation – decreases the value of variable $ x $ by 1.

A statement in language Bit++ is a sequence, consisting of exactly one operation and one variable $ x $ . The statement is written without spaces, that is, it can only contain characters “+”, “-”, “X”. Executing a statement means applying the operation it contains.

A programme in Bit++ is a sequence of statements, each of them needs to be executed. Executing a programme means executing all the statements it contains.

You’re given a programme in language Bit++. The initial value of $ x $ is $ 0 $ . Execute the programme and find its final value (the value of the variable when this programme is executed).

输入格式

The first line contains a single integer $ n $ $ (1<=n<=150) $ — the number of statements in the programme.

Next $ n $ lines contain a statement each. Each statement contains exactly one operation (++ or --) and exactly one variable $ x $ (denoted as letter «X»). Thus, there are no empty statements. The operation and the variable can be written in any order.

输出格式

Print a single integer — the final value of $ x $ .

样例 #1

样例输入 #1

1
++X

样例输出 #1

1

样例 #2

样例输入 #2

2
X++
--X

样例输出 #2

0

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;
string x="++",y="--";

int main()
{
    ll t;
    cin>>t;

    ll sum=0;
    while(t--)
    {
        string s;
        cin>>s;

        if(s.find(x)!=-1) sum++;
        if(s.find(y)!=-1) sum--;
    }

    cout<<sum<<endl;
    return 0;
}


  • 8
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值