Max Sum

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

###Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

###Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

###Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

###Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

###题目大意:
求一个序列的最大连续子序列和
###解题思路:
DP中的基本问题最大连续序列和,思想很简单,DP数组下标表示以当前位置为序列末尾,值表示当前序列的最大和,边界dp[1]=a[1],状态转移为 dp[i]=max(dp[i-1]+a[i],a[i]);。但本题坑点较多,一是对时间卡的比较严格,我特么专门为输入开一个循环竟然给了个TLE。还有就是输出空行问题,每个样例之间有一个空行,最后一个样例后面没有多余空行。另外关于边界的输出,右边界可以直接根据数组下标确定,左边界则需要动脑筋思考,当当前位置连续最大序列和小于0时,“可能的”左边界(或者说子序列的起点更好理解)要移动到当前位置的下一位,直到更新最大值时顺便更新左边界。
代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
  int n1,c=1;
  cin>>n1;
  while(n1--)
  {
    int a[100010]={0},l=1,r=1,ma=-999999,n,dp[100010]={0};
    cin>>n;
    int t=1;
    for(int i=1;i<=n;i++)
    {
      cin>>a[i];
      dp[i]=max(dp[i-1]+a[i],a[i]);
      if(dp[i]>ma)
      {
        ma=dp[i];
        l=t;//注意左边界的更新
        r=i;
      }
      if(dp[i]<0) t=i+1;//保存可能的左边界
    }
    cout<<"Case "<<c++<<":"<<endl;
    cout<<ma<<' '<<l<<' '<<r<<endl;
    if(n1) cout<<endl;//最后一个样例后无换行
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值