HDU-5933 ArcSoft's Office Rearrangement

Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are  N  working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into  K  new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into  K  block with equal size, please help him.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case begins with one line which two integers  N  and  K , which is the number of old blocks and new blocks.

The second line contains  N  numbers  a1 a2 aN , indicating the size of current blocks.

Limits
1T100
1N105
1K105
1ai105
 

Output
For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can't re-arrange  K  new blocks with equal size, y equals -1.
 

Sample Input
  
  
3 1 3 14 3 1 2 3 4 3 6 1 2 3
 

Sample Output
  
  
Case #1: -1 Case #2: 2 Case #3: 3
首先判断能否重新安排,如果可以就计算出平均值,也就是最后每个版块的大小。

从第一个版块开始,依次遍历一遍,1.大于平均值且不为平均值的倍数,将余下的部分并入下一版块。2.大于平均值且为平均值的倍数,直接平均划分。3.等于平均值,不作处理。4.小于平均值,并入下一版块。

需要使用long long,如果是int会超出范围。

#include<cstdio>
#include<cstring>
long long a[100005];
int main()
{
long long t,n,k,cnt,sum,ave;
scanf("%lld",&t);
for(int b=1;b<=t;b++)
{
    cnt=0;
    sum=0;
    memset(a,0,sizeof(a));
    scanf("%lld %lld",&n,&k);
    for(int i=0;i<n;i++)
        {scanf("%lld",&a[i]);
    sum+=a[i];}
    if(sum%k!=0) {
        printf("Case #%d: -1\n",b); continue;
    }
ave=sum/k;
for(int i=0;i<n;i++)
{
    if(a[i]>ave) {
          if(a[i]%ave!=0)  {cnt+=a[i]/ave+1;   a[i]-=ave*(a[i]/ave);
    a[i+1]+=a[i];}
   else {cnt+=a[i]/ave-1;}
     }
 else   if(a[i]==ave) {continue;}
    else {
        a[i+1]+=a[i] ; cnt++;
    }
}
     printf("Case #%d: %lld\n",b,cnt);
}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值