HDU 5933 - ArcSoft's Office Rearrangement (贪心)

32 篇文章 0 订阅

ArcSoft's Office Rearrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2455    Accepted Submission(s): 826


Problem Description
ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are  N  working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into  K  new blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the  minimum operations to re-arrange current blocks into  K  block with equal size, please help him.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case begins with one line which two integers  N  and  K , which is the number of old blocks and new blocks.

The second line contains  N  numbers  a1 a2 aN , indicating the size of current blocks.

Limits
1T100
1N105
1K105
1ai105
 

Output
For every test case, you should output  'Case #x: y', where  x indicates the case number and counts from  1 and  y is the minimum operations.

If the CEO can't re-arrange  K  new blocks with equal size,  y equals  -1.
 

Sample Input
  
  
3 1 3 14 3 1 2 3 4 3 6 1 2 3
 

Sample Output
  
  
Case #1: -1 Case #2: 2 Case #3: 3
 

Source
 

题意:
给你n个数,问你能不能平均分成k个数,问你操作次数最少几次。
操作1:合并【相邻】的两个数,操作2:把一个数拆成2个数。

POINT:
aim=sum/k。
一开始没看到相邻,做了3个小时。
操作是,从第一个开始便利,大于aim就切,剩余的合到下一个。就好了。


#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include <queue>
#include <functional>
using namespace std;
#define LL long long
const LL maxn = 1e5 + 6;
LL a[maxn];
int main()
{
	LL T, cas = 0;
	scanf("%lld", &T);
	while (T--) {
		LL n, k; scanf("%lld %lld", &n, &k);
		LL sum = 0;
		for (LL i = 1; i <= n; i++) {
			scanf("%lld", &a[i]);
			sum += a[i];
		}
		if (sum%k != 0) {
			printf("Case #%lld: -1\n", ++cas);
			continue;
		}
		LL aim = sum / k;
		LL ans = 0;
		for (LL i = 1; i<n; i++) {
			if (a[i]>aim) {
				LL num = a[i] / aim;
				ans += num;
				if (a[i] % aim == 0) ans--;
				else
					ans++;
				a[i] %= aim;
				a[i + 1] += a[i];
			}
			else if (a[i]<aim) {
				ans++;
				a[i + 1] += a[i];
			}
		}
		ans += a[n] / aim - 1;
		printf("Case #%lld: %lld\n", ++cas, ans);


	}


	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值