ArcSoft‘s Office Rearrangement (模拟操作,贪心)

ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new blocks by the following two operations:

  • merge two neighbor blocks into a new block, and the new block’s size is the sum of two old blocks’.
  • split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K block with equal size, please help him.
Input
First line contains an integer T, which indicates the number of test cases.

Every test case begins with one line which two integers N and K, which is the number of old blocks and new blocks.

The second line contains N numbers a1, a2, ⋯, aN, indicating the size of current blocks.

Limits
1≤T≤100
1≤N≤105
1≤K≤105
1≤ai≤105
Output
For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can’t re-arrange K new blocks with equal size, y equals -1.
Sample Input
3
1 3
14
3 1
2 3 4
3 6
1 2 3
Sample Output
Case #1: -1
Case #2: 2
Case #3: 3

题意:给你n个数,可以进行两种操作,如果能使其平均分成m个数,那么输出能满足的最少的操作数,否则输出-1.
两种操作:
1. 将两个相邻的块合并成一个新块,新块的大小是两个旧块的和。
2.将一个块拆分为两个新块,您可以指定每个块的大小,但总和应等于旧块。
解题思路:如果那个数和为除于m不等于零,一定不能分成m等份。否者,从左往右模拟,两种操作,贪心寻找最优解。

实现代码

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
LL t, i, n, sum, ans, a[100005], m, cnt = 1;                  //要使用longlong类型
int main() 
{
    scanf("%lld", &t);
    while (t--) 
    {
        sum = 0;
        ans = 0;
        scanf("%lld%lld", &n, &m);
        for (i = 0; i < n; i++) 
        {
            scanf("%lld", &a[i]);
            sum += a[i];
        }
        if (sum % m != 0)                                    //除于m不等于0
        {
            printf("Case #%lld: -1\n", cnt++);
            continue;
        }  
        sum /= m;                                            //使sum成为最终要分成的数值
        for (i = 0; i < n; i++) 
        {
            if (a[i] >= sum)                                 //模拟操作一,向右分一个数值为sum的块
            {
                ans += a[i] / sum;
                a[i] %= sum;
                if (a[i] == 0)                               //这种情况,上面多分了一次,所以要减一
                {                                            //例如a[i]=8,sum=4,其实只用分一次就可以
                    ans--;                                   
                } 
                else 
                {
                    ans++;                                  //模拟操作二,将剩余的数值加到下一块
                    a[i + 1] += a[i];
                }
            } 
            else 
            {
                ans++;                                      //模拟操作二,将数值加到下一块
                a[i + 1] += a[i];
            }
        }
        printf("Case #%lld: %lld\n", cnt++, ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值