Bubble Sort
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 502 Accepted Submission(s): 306
Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.
After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i) for(int j=N,t;j>i;—j) if(P[j-1] > P[j]) t=P[j],P[j]=P[j-1],P[j-1]=t;
After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.
limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.
limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.
Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
Sample Input
2 3 3 1 2 3 1 2 3
Sample Output
Case #1: 1 1 2 Case #2: 0 0 0HintIn first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3) the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3 In second case, the array has already in increasing order. So the answer of every number is 0.
题意:给定一个长为n的序列,对此序列进行冒泡升序排列,问每个位置上的数字所到过最右端和最左端的差值是多少。
#include <algorithm>
#include <iostream>
#include <numeric>
#include <cstring>
#include <iomanip>
#include <string>
#include <vector>
#include <cstdio>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const LL Max = (1LL<<32) - 1;
const double esp = 1e-6;
const double PI = 3.1415926535898;
const int INF = 0x3f3f3f3f;
using namespace std;
int t,n;
int arr[100005];
int cal[100005];
int L[100005],R[100005];
int lowbit(int x){
return x&(-x);
}
void updata(int x){
while(x <= n){
cal[x] += 1;
x += lowbit(x);
}
}
int query(int x){
int ans = 0;
while(x > 0){
ans += cal[x];
x -= lowbit(x);
}
return ans;
}
int main(){
int cas = 1;
scanf("%d",&t);
while(t-- && scanf("%d",&n)){
for(int i=0;i<n;i++){
scanf("%d",&arr[i]);
R[arr[i]] = max(i + 1,arr[i]);
}
memset(cal,false,sizeof(cal));
for(int i=0;i<n;i++){
int ans = query(arr[i]);
L[arr[i]] = ans + 1;
updata(arr[i]);
}
printf("Case #%d:",cas++);
for(int i=1;i<=n;i++){
printf(" %d",R[i] - L[i]);
}
printf("\n");
}
return 0;
}