[Poj 3278] Catch That Cow BFS

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 69092 Accepted: 21729

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

三种情况的bfs建边;

#include<iostream>
#include<queue>
#include<stdio.h>
#include<string.h>
using namespace std;
int vis[200030];
struct node{
    int x,step;
    node(int xx,int st)
    {
        x=xx;
        step=st;
    }node(){}
};
queue<node> q;
int ans;
int x,k;
int flag=0;
void bfs()
{
    q.push(node(x,0));
    vis[x]=1;
    while(!q.empty())
    {
        node now=q.front();
        q.pop();
        if(flag==1) break;
        int mx=x*2;
        if(now.x>0&&vis[now.x-1]==0)
        {
            if(now.x-1==k) 
            {
                flag=1;
                ans=now.step+1;
            }
            vis[now.x-1]=1;
            q.push(node(now.x-1,now.step+1));
        }
        if(now.x<k&&vis[now.x+1]==0)
        {
            if(now.x+1==k) 
            {
                flag=1;
                ans=now.step+1;
            }
            vis[now.x+1]=1;
            q.push(node(now.x+1,now.step+1));
        }
        if(now.x<k&&vis[now.x*2]==0)
        {
            if(now.x*2==k) 
            {
                flag=1;
                ans=now.step+1;
            }
            vis[now.x*2]=1;
            q.push(node(now.x*2,now.step+1));
        }
    }
}

int main()
{
    scanf("%d%d",&x,&k);
    bfs();
    printf("%d\n",ans);

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值