F - Aggressive cows

典型的最大化最小值问题。

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9
Sample Output
3


思路:我们根据题意可以知道,这题的意思是给出n个牛舍坐标(在一直线上),然后有m个牛要入住,现在问相邻牛之间的最小距离最大是几 ,通俗的说就是一条线段上有 n 个点,选取 m 个点,使得相邻点之间的最小距离值最大。

输入进来的牛舍的距离是无序的,所以先排序,二分枚举可能的距离, 查看是否能把所有的奶牛全部安排开,若不能,压缩上界, 若能压缩下界找更优解。

#include<iostream> 
#include<algorithm>  
using namespace std;
int a[100005];
int n, m;
int fun(int mid)//对于给的mid值,看是否能将所有的奶牛安排开。
{
int p = 0;
int count = 1;
for (int i = 1; i<n; i++)
{
if (a[i] - a[p] >= mid)
{
p = i;
count++;
}
}
if (count >= m)
return 1;
else 
return 0;
}
int main()
{
cin >> n >> m;
for (int i = 0; i < n; i++)
cin >> a[i];
sort(a, a + n);
int sum;
int l = 0;
int r = a[n - 1] - a[0];//最大的值不可能大于开头和结尾的差的距离。
while (r >= l)
{
int mid = (l + r) / 2;
if (fun(mid) == 1)
{
sum = mid;
l = mid + 1;
}
else
r = mid - 1;
}
cout << sum << endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值