POJ 2253 Frogger 最小生成树

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 49358 Accepted: 15711

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
AC代码:
#include<algorithm>
#include<iomanip>
#include<iostream>
#include<cstring>
#include<cmath>
#include<math.h>
#include<cstdio>
#define maxn 300
#define inf  1e7
//算法思路:找到一条能连通前两个坐标的最短路。用kruskal最小生成树思想按路径长度从小到大排列结点,当刚好连通时的结点长度就是minimax
using namespace std;
typedef struct
{
   int  p1;
   int  p2;
   double lenth;
}coordinates;
coordinates c[maxn*maxn];
double X[maxn],Y[maxn];//用于存储对应各点的x,y坐标
int found[maxn];//并查集
int cnt;
void init()
{
   cnt=0;
   for(int i=0;i<maxn;i++) found[i]=i;//并查集初始化
   memset(X,0,sizeof(X));
   memset(Y,0,sizeof(Y));
}
int find(int x)
{
	if(x==found[x] ) return x;
	return  find(found[x]);
}

double getlenth(int i,int j)
{
	 return sqrt((X[i]-X[j])*(X[i]-X[j])+(Y[i]-Y[j])*(Y[i]-Y[j]));
     //return hypot(fabs(X[i]-X[j]),fabs(Y[i]-Y[j]));//求两点距离
}

void input(int n)
{
    for(int i=0;i<n;i++)
	   cin>>X[i]>>Y[i];
	for(int i=0;i<n;i++)
	{
		for(int j=i+1;j<n;j++)
		{
			if(i==j) continue;
			c[cnt].p1=i;
			c[cnt].p2=j;
			c[cnt++].lenth=getlenth(i,j);
		}
	}

}
bool cmp(coordinates x, coordinates y)
{
	return x.lenth<y.lenth;
}

double kruskal()
{
	sort(c,c+cnt,cmp);
	double ans=inf;
	for(int i=0;i<cnt;i++)
	{
		int p=find(c[i].p1);
		int q=find(c[i].p2);
		if(p!=q)
		{
		found[p]=q;
		if(find(0)==find(1))//第一个点已经和第二个点连通,获得最短路,输出目前的长度即为最大距离
                return c[i].lenth;
	        }
	}
	return ans;
}
int main(void)
{
	int T=1;
	int n;
	while(cin>>n&&n)
	{
        init();
        input(n);
	double len=kruskal();
	cout<<"Scenario #"<<T++<<endl<<"Frog Distance = "<<setiosflags(ios::fixed)<<setprecision(3)<<len<<endl<<endl;
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值