最大匹配(1)--poj3041(最大匹配的应用 最大匹配=最小点覆盖数)

                                   A - Asteroids

 

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
Hint
INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

         这道题题意: 给一个N*N的矩阵 ,有些格子有障碍,要求我们消除这些障碍,问每次消除一行或一列的障碍,

最少要几次。这里将每行x看成一个X结点,每列Y看成一个Y结点,障碍的坐标x,y看成X到Y的

一条边,构建出图后,就变成了找最少的点,使得这些点与所有的边相邻,即最小点覆盖问题。

把每一列当成一个点,每一行当成一个点,若行节点和列节点之间有边,则表明该行列该列有一个障碍物。 主要是构图:将每一行当成一个点,构成集合1, 每一列也当成一个点,构成集合2;每一个障碍物的位置坐标将集合1与集合2中的点连接起来,也就是将每一个障碍物作为连接节点的边。这样可以轻易的得出本题是一个最小点覆盖的问题,假设1个行节点覆盖了5个列节点,即这个行节点与这5个列节点间有5条边(即五个障碍物),由于这5条边都被那个行节点覆盖,即表明这5个障碍物都在同一列上,于是可以一颗炸弹全部清除,而本题也就转化成求最小点覆盖数的问题。

又有一个定理是:最小点覆盖数 = 最大匹配数, 所以此题转化成求最大匹配数。

以下是匈牙利算法的代码:

//  main.cpp
//  temp
//
//  Created by Sly on 2017/2/21.
//  Copyright © 2017年 Sly. All rights reserved.
//

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int map[505][505];
int link[505];
int used[505];
int N;
bool Find(int x)
{
    int i;
    for(i=1;i<=N;i++)
    {
        if(used[i]==0&&map[x][i]==1)
        {
            used[i]=1;
            if(link[i]==0||Find(link[i]))
            {
                link[i]=x;
                return true;
            }
        }
    }
    return false;
}
int main() {
    int K,num;
    while(scanf("%d %d",&N,&K)!=EOF)
    {
        num=0;
        int a,b,i;
        memset(map,0,sizeof(map));
        for(i=0;i<K;i++)
        {
            scanf("%d %d",&a,&b);
            map[a][b]=1;
        }
        memset(link,0,sizeof(link));
        for(i=1;i<=N;i++)
        {
            memset(used,0,sizeof(used));
            if(Find(i))num+=1;
        }
        cout<<num<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值