UPC7817: Supermarket

UPC7817: Supermarket

时间限制: 1 Sec  内存限制: 128 MB
提交: 49  解决: 11
[提交] [状态] [讨论版] [命题人:admin]
题目描述
A supermarket has a set Prod of products on sale. It earns a profit px for each product x⊆Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell  Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dxor just when dx expires. The profit of the selling schedule is 
An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. 
For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 
Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

 

输入
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct. 

 

输出
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

 

样例输入

复制样例数据

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10
样例输出
80
185

 

提示

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

 
按照d从小到大排序,然后用优先队列维护前d大的商品,最后求队列中所有元素的价值总和即可
 
#include "bits/stdc++.h"
 
using namespace std;
typedef long long ll;
const int maxn = 1e5 + 100;
 
 
struct node {
    int p, d;
} e[maxn];
 
bool cmp(node a, node b) {
    return a.d < b.d;
}
 
priority_queue<int, vector<int>, greater<int> > q;
 
int main() {
    //freopen("input.txt", "r", stdin);
    int n;
    while (cin >> n) {
        while (!q.empty()) q.pop();
        for (int i = 1; i <= n; i++) {
            cin >> e[i].p >> e[i].d;
        }
        sort(e + 1, e + 1 + n, cmp);
        for (int i = 1; i <= n; i++) {
            int size = q.size();
            if (size < e[i].d) q.push(e[i].p);
            else if (e[i].p > q.top()) {
                q.pop();
                q.push(e[i].p);
            }
        }
        int ans = 0;
        while (!q.empty()) {
            ans += q.top();
            q.pop();
        }
        cout << ans << endl;
    }
    return 0;
}

 

 
posted @ 2019-03-06 09:19 Albert_liu 阅读( ...) 评论( ...) 编辑 收藏
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值