hdu1253 胜利大逃亡

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39146    Accepted Submission(s): 13742


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
  
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
  
  
11

#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;

int mat[50][50][50];
int visit[50][50][50];
//int visit[50][50][50];
int l[6]={1,-1,0,0,0,0};
int m[6]={0,0,1,-1,0,0};
int r[6]={0,0,0,0,1,-1};
int T,a,b,c;

struct node{
	int x,y,z;
	int sum;
};
queue<node>p;
int judge(node t){
	if(t.x>=0&&t.y>=0&&t.z>=0&&t.x<a&&t.y<b&&t.z<c)
	return 1;
	return 0;
}

void bfs(){
	node k;
	k.x =0;k.y =0;k.z =0;
	k.sum =0;
	p.push(k);
	while(!p.empty()){
		node t;
		t=p.front();
		p.pop();
		if(t.sum>T){
			printf("-1\n");
			return ;
		}
		if(t.x==a-1&&t.y==b-1&&t.z==c-1){
			printf("%d\n",t.sum );
			return ;
		}
		else{
			for(int i=0;i<6;i++){
			node s;
			 s.x = t.x + l[i];
			 s.y = t.y + m[i];
			 s.z = t.z + r[i];
			s.sum = t.sum + 1;
			 if(judge(s)&&!mat[s.x ][s.y][s.z]&&!visit[s.x ][s.y ][s.z ]){
			 	p.push(s);
			 	visit[s.x ][s.y ][s.z ]=1;
				}
			}
		}
	}
	printf("-1\n");
}

int main()
{
	int n;
	scanf("%d",&n);
	while(n--){
		memset(mat,1,sizeof(mat)); 
		memset(visit,0,sizeof(visit));
		scanf("%d%d%d%d",&a,&b,&c,&T);
		for(int i=0;i<a;i++){
			for(int j=0;j<b;j++){
				for(int m=0;m<c;m++)
				scanf("%d",&mat[i][j][m]);
			}
		}
	//	if(a+b+c-3>T) 加不加时间没有多大变化,不加反而时间短 
	//	printf("-1\n");
		/*else*/ bfs();
	}
	return 0;
}

超时代码

//超时 
#include<stdio.h>
#include<string.h>
using namespace std;
int mat[51][51][51];
int a[6]={1,-1,0,0,0,0};
int b[6]={0,0,1,-1,0,0};
int c[6]={0,0,0,0,1,-1};
int d[51][51][51];
int a1,b1,c1,t,k;
int ans;

void dfs(int x,int y,int z,int n){
	if(x==a1&&y==b1&&z==c1){
		if(n<ans)
		ans=n;
		return ;
	}
	for(int i=0;i<6;i++){
		int xx=x+a[i];
		int yy=y+b[i];
		int zz=z+c[i];
		if(!mat[xx][yy][zz]&&xx>=0&&yy>=0&&zz>=0&&xx<=a1&&yy<=b1&&zz<=c1){
			mat[xx][yy][zz]=1;
			dfs(xx,yy,zz,n+1);
			mat[xx][yy][zz]=0;
		}
	}
	
}
int main(){
	scanf("%d",&k);
	while(k--){
		int n=0;
		ans=10000;
		memset(mat,1,sizeof(mat));
		memset(d,0,sizeof(d));
		scanf("%d%d%d%d",&a1,&b1,&c1,&t);
		for(int i=1;i<=a1;i++){
			for(int j=1;j<=b1;j++){
				for(int m=1;m<=c1;m++)
				scanf("%d",&mat[i][j][m]);
			}
		}
		if(a1+b1+c1-3>t)
		printf("-1\n");
		else{
			dfs(1,1,1,n);
			if(ans<=t)
			printf("%d\n",ans);
			else printf("-1\n");
		}	
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值