POJ 1611:The Suspects

总时间限制: 1000ms 内存限制: 65536kB

描述
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

输入
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

输出
For each case, output the number of suspects in one line.

样例输入
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

样例输出
4
1
1

描述
严重急性呼吸道综合症(SARS)是一种病因不明的非典型肺炎,在2003年3月中旬被认为是全球性威胁。为了最大程度地减少向他人的传播,最好的策略是将嫌疑犯与其他人分开。
在不蔓延疾病大学(NSYSU)中,有很多学生团体。同一组中的学生经常互相交流,一个学生可以加入多个组。为了防止SARS的可能传播,NSYSU收集所有学生团体的成员列表,并在其标准操作程序(SOP)中制定以下规则。
一旦组中的某个成员成为可疑对象,该组中的所有成员都是可疑对象。
但是,他们发现,当一个学生被确认为犯罪嫌疑人时,要识别所有犯罪嫌疑人并不容易。您的工作是编写一个找到所有嫌疑犯的程序。

输入
输入文件包含几种情况。每个测试用例均以一行中的两个整数n和m开头,其中n是学生数,m是组数。您可以假设0 <n <= 30000并且0 <= m <=500。每个学生都用0到n-1之间的唯一整数编号,并且最初在所有情况下,学生0都被认为是可疑者。该行之后是组的m个成员列表,每组一行。每行以一个整数k开头,该整数k代表组中成员的数量。在成员数之后,有k个整数表示该组中的学生。一行中的所有整数至少间隔一个空格。
n = 0和m = 0的情况表示输入的结束,无需处理。

输出
对于每种情况,在一行中输出可疑对象的数量。

解题思路
并查集模板题

代码:

#include<iostream>
using namespace std;
int pre[30005],a[30005];
int n,m;

//并查集 
void Init()//初始化 
{
	for(int i=0;i<=n;i++)
	pre[i]=i;
}
int findRoot(int x)//找根
{
	if(x==pre[x]) return x;
	return findRoot(pre[x]);
} 
void merge(int x,int y)//合并集合 
{
	int a=findRoot(x);
	int b=findRoot(y);
	if(a!=b) pre[b]=a;
}

int main()
{
	std::ios::sync_with_stdio(false);
	cin.tie(0);cout.tie(0);
	
	while((cin>>n>>m)&&(n||m))
	{
		int k,cnt=0;
		Init();//初始化 
		for(int i=0;i<m;i++)
		{
			cin>>k;
			for(int j=0;j<k;j++)
			{
				cin>>a[j];
				if(j>0)
				merge(a[j-1],a[j]);//合并 
			}
		} 
		
		for(int i=0;i<n;i++)
		{
			if(findRoot(i)==findRoot(0)) 
			cnt++;
		}
		cout<<cnt<<endl;
	}
	return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值