PAT-A1006 Sign In and Sign Out 题目内容及题解

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意

题目给出一系列打卡记录,从中找出到的最早的和离开最晚的人,并按照格式分别输出其ID。

解题思路

  1. 初始化早晚对比值;
  2. 依次读入记录,并将其与早晚对比值分别进行对比及更新;
  3. 输出结果并返回0值。

代码

#include<stdio.h>
struct People{
    char ID[20];
    int begin;
    int end;
}unlock,lock,temp;

int gettime(int hour,int min,int second){
    return 3600*hour+60*min+second;
}
void init(){
    unlock.begin=gettime(23,59,59)+1;
    lock.end=-1;
}

int main(){
    int M;
    int i;
    int hour,minute,second;
    init();
    scanf("%d",&M);
    getchar();
    for(i=0;i<M;i++){
        scanf("%s",&temp.ID);
        scanf(" %d:%d:%d",&hour,&minute,&second);
        temp.begin=gettime(hour,minute,second);
        scanf(" %d:%d:%d",&hour,&minute,&second);
        temp.end=gettime(hour,minute,second);
        getchar();
        if(temp.begin<unlock.begin){
            unlock=temp;
        }
        if(temp.end>lock.end){
            lock=temp;
        }
    }
    printf("%s %s\n",unlock.ID,lock.ID);
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值