PAT-A1009 Product of Polynomials 题目内容及题解

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题目大意

题目给出A和B两个多项式,求出其积多项式并按照规定格式输出。

解题思路

  1. 分别读入两个多项式;
  2. 两个多项式各项依次相乘,并对指数相同的项的系数做合并;
  3. 按照题目要求从大到小输出多项式并返回0值。

代码

#include<stdio.h>
#include<math.h>

#define err 1E-7
#define MAXN 1005

struct POLY{
    int K;
    double cof[MAXN];
    int exp[MAXN];
}a,b;

int main(){
    int i,j,num=0,max;
    double cof,res[2*MAXN];
    int exp;
    scanf("%d",&a.K);
    for(i=0;i<a.K;i++){
        scanf("%d%lf",&a.exp[i],&a.cof[i]);
    }
    scanf("%d",&b.K);
    for(i=0;i<b.K;i++){
        scanf("%d%lf",&b.exp[i],&b.cof[i]);
    }
    max=a.exp[0]+b.exp[0];
    for(i=0;i<=max;i++){
        res[i]=0.0;
    }
    for(i=0;i<a.K;i++){
        for(j=0;j<b.K;j++){
            exp=a.exp[i]+b.exp[j];
            cof=a.cof[i]*b.cof[j];
            if(fabs(res[exp])<err){
                res[exp]=cof;
                num++;
            }else{
                res[exp]+=cof;
                if(fabs(res[exp])<err){
                    num--;
                }
            }
        } 
    }
    printf("%d ",num);
    for(i=max;i>=0;i--){
        if(fabs(res[i])>err){
            printf("%d %.1lf",i,res[i]);
            num--;
            if(num>0){
                printf(" ");
            }else{
                printf("\n");
            }
        }
    }
    return 0;
}

运行结果

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值