PAT-A1017 Queueing at Bank 题目内容及题解

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题目大意

题目给定某银行的窗口数和顾客的到来时间以及服务所需时间,题目要求给出所有顾客的平均等待时间。每窗口服务一名顾客,共用队列,迟到者不被计数。

解题思路

  1. 窗口只服务一名顾客,可以用数组表示,记录可以服务下一名顾客的时间(开门营业时间或者服务完当前顾客的时间);
  2. 顾客需要记录到来时间与服务所需的时间,如迟到则记录可以在记录阶段直接丢掉,反之,17:00前加入队伍的顾客无论如何可以得到服务,每一名可以得到服务的客户可在到来时加入完成时间最早的队伍,并更新该窗口信息;
  3. 顾客接受服务的时间为窗口空闲时间与到达时间取较大值,其差值为等待时间;
  4. 记录总等待时间,计算并输出平均等待时间,返回0值。

代码

#include<stdio.h>

#define MAXN 10010
#define INF 100000000
#define OP 8*3600
#define CL 17*3600

struct Custom{
    int arrive,service;//到达时间,服务时间
}cus[MAXN];//顾客

int Sort[MAXN]; 

int win[110];//窗口结束时间 

int N,K;//顾客数,窗口数
int num=0;//有效数 
int T=0;//时间 

void Swap(int i,int j){
    int t;
    t=Sort[i];
    Sort[i]=Sort[j];
    Sort[j]=t;
    return;
}//交换 

void Init(){
    int i;
    int h,m,s,work,arr;
    scanf("%d%d",&N,&K);
    while(N--){
        scanf("%d:%d:%d %d",&h,&m,&s,&work);
        arr=(h*60+m)*60+s;
        if(arr>CL){
            continue;
        }//到达时间晚于关门时间,不被记录,直接略过 
        cus[num].arrive=arr;
        cus[num].service=work*60;
        //读入 
        Sort[num]=num;
        for(i=num;i>0;i--){
            if(cus[Sort[i]].arrive<cus[Sort[i-1]].arrive){
                Swap(i,i-1);
            }else{
                break;
            }
        }//冒泡排序 
        num++;
    }
    for(i=0;i<K;i++){
        win[i]=OP;
    }
    return;
}

void Print(){
    int i,j,Wait=0;
    int jm,Min_Time; 
    for(i=0;i<num;i++){
        jm=-1;
        Min_Time=INF;
        for(j=0;j<K;j++){
            if(win[j]<Min_Time){
                jm=j;
                Min_Time=win[j];
            }
        }
        if(win[jm]>cus[Sort[i]].arrive){//来得早 
            Wait+=win[jm]-cus[Sort[i]].arrive;//等待时间 
            win[jm]+=cus[Sort[i]].service;//更新窗口 
        }else{
            win[jm]=cus[Sort[i]].arrive+cus[Sort[i]].service;//窗口时间更新为服务完i; 
        } 
    } 
    printf("%.1lf\n",(1.0*Wait)/(60.0*num));
    return;
}

int main(){
    int i; 
    Init();
    Print();
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值