PAT-A1024 Palindromic Number 题目内容及题解

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10^​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题目大意

非回文数可以通过一系列操作与回文数对应,题目给出任意正整数,检验其是否为回文数,如非回文,则将其与其逆置相加;直到其成为回文数或者达到上线操作次数后停止,并输出结果。

解题思路

  1. 使用字符串形式保存大整数;
  2. 每步先判断是否回文再相加;
  3. 成为回文数或到达尝试上限后停止操作,输出结果并返回0值。

代码

#include<stdio.h>
#include<string.h>
#define maxn 10000
char num[maxn];
void add(){
    char temp[maxn];
    int i=0,j,k=0;
    int c=0,sum;
    for(j=strlen(num)-1;j>=0;){
        sum=num[i]+num[j]+c-96;
        c=sum/10;
        sum=sum%10;
        temp[k++]=sum+'0';
        j--;
        i++;
    }
    if(c==1){
        temp[k++]='1';
    }
    for(i=0,j=k-1;j>=0;){
        num[i]=temp[j];
        i++;
        j--;
    }
    num[k]=0;
    return;
}

int check(){
    int i=0,j;
    j=strlen(num)-1;
    while(i<j){
        if(num[i]!=num[j]){
            return 0;
        }
        i++;
        j--;
    }
    return 1;
}
int main(){
    int n,i=0;
    scanf("%s %d",&num,&n);
    while(i<n){
        if(check()){
            break;
        }else{
            i++;
            add();
        }
    }
    printf("%s\n%d\n",num,i);
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值