PAT-A1043 Is It a Binary Search Tree 题目内容及题解

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意

题目给定一个前序遍历序列,检查其是否是二叉搜索树或其镜像二叉搜索树的前序遍历序列。如果是,则返回该二叉树的后序遍历序列;如不是,返回“NO”。

解题思路

  1. 编写插入二叉搜索树和镜像二叉搜索树的函数;
  2. 保存读入的前序序列为初始序列,并将其按顺序插入二叉搜索树;
  3. 前序遍历该树并将遍历结果与初始序列比较,如一致则输出该树后序遍历并返回零值;
  4. 如不一致,则将前序序列按顺序插入镜像二叉搜索树;
  5. 前序遍历该树并将遍历结果与初始序列比较,如一致则输出该树后序遍历并返回零值;
  6. 如仍不一致,输出“NO”并返回零值。

代码

#include<cstdio>
#include<vector>
using namespace std;

vector<int> pre,post,Origin;

struct Node{
    int data;
    Node *lchild,*rchild;
};

void Insert(Node* &root,int v){
    if(root==NULL){
        root=new Node;
        root->data=v;
        root->lchild=NULL;
        root->rchild=NULL;
        return;
    }
    if(v<root->data){
        Insert(root->lchild,v);
    }else{
        Insert(root->rchild,v);
    }
    return;
}

void InsertM(Node* &root,int v){
    if(root==NULL){
        root=new Node;
        root->data=v;
        root->lchild=NULL;
        root->rchild=NULL;
        return;
    }
    if(v>=root->data){
        InsertM(root->lchild,v);
    }else{
        InsertM(root->rchild,v);
    }
    return;
}

void PreO(Node* root){
    if(root==NULL){
        return;
    }
    pre.push_back(root->data);
    PreO(root->lchild);
    PreO(root->rchild);
}

void PostO(Node* root){
    if(root==NULL){
        return;
    }
    PostO(root->lchild);
    PostO(root->rchild);
    post.push_back(root->data);
}

int main(){
    Node *root=NULL,*rootM=NULL;
    int N,i,a;
    scanf("%d",&N);
    Origin.clear();
    for(i=0;i<N;i++){
        scanf("%d",&a);
        Insert(root,a);
        Origin.push_back(a);
    }
    pre.clear();
    PreO(root);
    if(pre==Origin){
        printf("YES\n");
        post.clear();
        PostO(root);
        for(i=0;i<N;i++){
            printf("%d",post[i]);
            if(i<N-1){
                printf(" ");
            }else{
                printf("\n");
            }
        }
    }else{
        for(i=0;i<Origin.size();i++){
            InsertM(rootM,Origin[i]);
        }
        pre.clear();
        PreO(rootM);
        if(pre==Origin){
            printf("YES\n");
            post.clear();
            PostO(rootM);
            for(i=0;i<N;i++){
                printf("%d",post[i]);
                if(i<N-1){
                    printf(" ");
                }else{
                    printf("\n");
                }
            }
        }else{
            printf("NO\n");
        }
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值