PAT-A1063 Set Similarity 题目内容及题解

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​^9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题目大意

题目给定若干个整数集,和一个请求序列。题目要求输出每对整数集的相似程度,并精确到小数点后一位。所谓相似程度即为两个整数集中(共有的元素数/两个集合中共有的不重复元素数)的百分比形式。

解题思路

读入题目给定的数据,并用set存储;

建立比较函数,以其中一个集合为基础,不重复元素总数设置为该集合的大小;

另一个集合中的每个元素在基础集合中进行查找操作,如查找到,则共有元素数加1,否则不重复元素总数加1;

依次读入对比序列,并按格式输出;

返回零值;

代码

#include<cstdio>
#include<set>
using namespace std;

set<int> St[60];

void check(int a,int b){
    int c=St[b].size(),s=0;
    set<int>::iterator it;
    for(it=St[a].begin();it!=St[a].end();it++){
        if(St[b].find(*it)!=St[b].end()){
            s++;
        }else{
            c++;
        }
    }
    printf("%.1lf%\n",(100.0*s)/c);
}

int main(){
    int N,M,K;
    int v,a,b;
    int i,j;
    scanf("%d",&N);
    for(i=1;i<=N;i++){
        scanf("%d",&M);
        for(j=0;j<M;j++){
            scanf("%d",&v);
            St[i].insert(v);
        }
    }
    scanf("%d",&K);
    for(i=0;i<K;i++){
        scanf("%d%d",&a,&b);
        check(a,b);
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值