PAT A1071

  • 题目:
    People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?
Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].
Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.
Sample Input:

Can1: “Can a can can a can? It can!”

Sample Output:

can 5

  • 题目大意
    输出一串字符,字符串由 集合[0-9 A-Z a-z]中的字符组成,从输出的字符串中找出出现次数最多的字符串,字母大小写视为相同。

  • 分析
    建立一个string 到int 的映射mp,mp中存储的为转化为小写后的字符串的出现次数
    现在主要解决要解决的问题为:
    将字符中的每一个字符串分出来
    注:map<string, int>mp 中,mp的初始值为0,直接计数即可,不需要开不变数组存储下标的值

while( i < len){
        string temp;
        while((str[i] >='0' && str[i] <='9') || (str[i] >='a' && str[i] <='z') || (str[i] >='A' && str[i] <='Z')){
            temp += tolower(str[i]);
            i++;
        }

        mp[temp] = 0;
        while(i < len){                     //找到第一个在这些区间的值
            if((str[i] >='0' && str[i] <='9') || (str[i] >='a' && str[i] <='z') || (str[i] >='A' && str[i] <='Z'))
                break;
            else
                i++;
            }
    }
  • 代码实现
#include <map>
#include <string>
#include <iostream>
#include <vector>
#include <cctype>
using namespace std;
int main ()
{
    string str;
    getline(cin, str);
    map<string , int> mp;
    int i = 0,  len = str.length();
    while( i < len){
        string temp;
        while((str[i] >='0' && str[i] <='9') || (str[i] >='a' && str[i] <='z') || (str[i] >='A' && str[i] <='Z')){
            temp += tolower(str[i]);
            i++;
        }

        mp[temp]++;
        while(i < len){                     //找到第一个在这些区间的值
            if((str[i] >='0' && str[i] <='9') || (str[i] >='a' && str[i] <='z') || (str[i] >='A' && str[i] <='Z'))
                break;
            else
                i++;
            }
    }
    string res1;
    int Max = 0;
    for(auto it = mp.begin(); it != mp.end(); it++){
        if(it->second > Max){
            res1 = it->first;
            Max = it->second;
        }
    }
    cout << res1 << " "<< Max;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值