PAT-A1095 Cars on Campus 题目内容及题解

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​^4​​), the number of records, and K (≤8×10^​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

题目大意

题目给出了车辆进出的信息,和一个时间的请求序列,要求输出该请求序列中任何一个特定的时间点校园里停了多少辆车,并且在一天结束的时候找出停了最长时间的车。

解题思路

  1. 初始化并读入车辆进出信息,并按照车牌号、记录时间进行排序;
  2. 筛选出其中的合法记录并标记,同时找出停车最长时间的车辆的车牌号和停车时间;
  3. 将合法记录按照记录时间重新排序;
  4. 模拟进出记录进行计数,按顺序读取请求时间并给出当时的停车信息;
  5. 按照题目要求输出结果并返回零值。

代码

#include<cstdio>
#include<iostream>
#include<string>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;

int N,K;


struct Record{
    string plate_number;
    int time;
    int status;
    int vivid;
};

bool cmp1(Record a,Record b){
    if(a.plate_number!=b.plate_number){
        return a.plate_number<b.plate_number;
    }else{
        return a.time<b.time;
    }
}//记录排序 

bool cmp2(Record a,Record b){
    if(a.vivid!=b.vivid){
        return a.vivid>b.vivid;
    }else{
        return a.time<b.time;
    }
}//记录排序 

vector<Record> Seq;
map<string,int> mp;
vector<string> Max;
int M=-1; 

int main(){
    char PN[10],st[5];
    int h,m,s;
    int vivid=0,count=0;
    int i,j,time,current;
    Record temp;
    scanf("%d%d",&N,&K);
    for(i=0;i<N;i++){
        scanf("%s %d:%d:%d %s",PN,&h,&m,&s,st);
        temp.plate_number=PN;
        temp.time=3600*h+60*m+s;
        temp.vivid=0;
        if(st[0]=='i'){
            temp.status=0;//in
        }else{
            temp.status=1;//out
        }
        Seq.push_back(temp);
    }
    sort(Seq.begin(),Seq.end(),cmp1);
    for(i=0;i<N;){
        if(Seq[i].plate_number==Seq[i+1].plate_number&&Seq[i].status==0&&Seq[i+1].status==1){
            Seq[i].vivid=1;
            Seq[i+1].vivid=1;
            vivid+=2;
            if(mp.find(Seq[i].plate_number)==mp.end()){
                mp[Seq[i].plate_number]=Seq[i+1].time-Seq[i].time;
            }else{
                mp[Seq[i].plate_number]+=Seq[i+1].time-Seq[i].time;
            }
            if(mp[Seq[i].plate_number]>M){
                Max.clear();
                Max.push_back(Seq[i].plate_number);
                M=mp[Seq[i].plate_number];
            }else if(mp[Seq[i].plate_number]==M){
                Max.push_back(Seq[i].plate_number);
            }
            i+=2;
        }else{
            i+=1;
        }
    }
    sort(Seq.begin(),Seq.end(),cmp2);
    j=0,current=0;
    Seq.push_back(temp);
    Seq[vivid].time=100000000;
    for(i=0;i<K;i++){
        scanf("%d:%d:%d",&h,&m,&s);
        time=3600*h+60*m+s;
        if(current>time){
            printf("%d\n",count);
        }else{
            for(;j<vivid;){
                if(current>time){
                    break;
                }else{
                    if(Seq[j].status==0){
                        count++;
                    }else{
                        count--;
                    }
                    j++;
                    current=Seq[j].time;
                    if(current>time){
                        printf("%d\n",count);
                        break;
                    }
                }
            }
        }
    }
    for(i=0;i<Max.size();i++){
        cout<<Max[i]<<" ";
    }
    h=M/3600;
    m=M%3600;
    s=m%60;
    m=m/60;
    printf("%02d:%02d:%02d\n",h,m,s);
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值