PAT-A1116/B1059 Come on! Let's C/C语言竞赛 题目内容及题解

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

C 语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:

  • 0、冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
  • 1、排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
  • 2、其他人将得到巧克力。

给定比赛的最终排名以及一系列参赛者的 ID,你要给出这些参赛者应该获得的奖品。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

输入第一行给出一个正整数 N(≤10​4​​),是参赛者人数。随后 N 行给出最终排名,每行按排名顺序给出一位参赛者的 ID(4 位数字组成)。接下来给出一个正整数 K 以及 K 个需要查询的 ID。

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

对每个要查询的 ID,在一行中输出 ID: 奖品,其中奖品或者是 Mystery Award(神秘大奖)、或者是 Minion(小黄人)、或者是 Chocolate(巧克力)。如果所查 ID 根本不在排名里,打印 Are you kidding?(耍我呢?)。如果该 ID 已经查过了(即奖品已经领过了),打印 ID: Checked(不能多吃多占)。

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

解题思路

  1. 建立结构体储存学生状态;
  2. 初始化并读入数据及查询序列;
  3. 对查询序列中每个查询请求进行查询并输出结果;
  4. 返回零值。

代码

#include<stdio.h>
#include<math.h>
#define maxn 10010
int N,K;
struct S{
    int rank;
    int checked;
}stu[maxn];

void Init(){
    int i,a;
    scanf("%d",&N);
    for(i=1;i<=N;i++){
        scanf("%d",&a);
        stu[a].rank=i;
    }
    scanf("%d",&K);
}

int isPrime(int x){
    int i,sq=(int)sqrt(1.0*x);
    if(x==1){
        return 0;
    }
    for(i=2;i<=sq;i++){
        if(x%i==0){
            return 0;
        }
    }
    return 1;
}

void Check(int v){
    if(stu[v].rank==0){
        printf("%04d: Are you kidding?\n",v);
        return;
    }
    if(stu[v].checked==1){
        printf("%04d: Checked\n",v);
        return;
    }else{
        stu[v].checked=1;
        if(stu[v].rank==1){
            printf("%04d: Mystery Award\n",v);
        }else if(isPrime(stu[v].rank)){
            printf("%04d: Minion\n",v);
        }else{
            printf("%04d: Chocolate\n",v);
        }
    }
}

int main(){
    int a;
    Init();
    while(K--){
        scanf("%d",&a);
        Check(a);
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值