PAT-A1147 Heaps 题目内容及题解

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题目大意

题目给定若干组完全二叉树的层次遍历,要求对每个完全二叉树判断其是否是大根堆/小根堆/不是堆,并输出其后序遍历序列。

解题思路

  1. 分别编制检查大根堆、小根堆的判断函数,依次判断每个节点是否符合大根堆或小根堆的条件;
  2. 编制输出后序遍历的函数;
  3. 对每棵待检测的完全二叉树,先读取并记录二叉树(从1号位置开始),并依据前两个元素的大小关系选择判断函数,并用输出后序遍历;
  4. 完成所有检测后返回零值。

代码

#include<stdio.h>
#define maxn 1010
int Heap[maxn];
int M,N,seq;
void Check1(){//Max;
    int i,j;
    for(i=N/2;i>=1;i--){
        j=2*i;
        if(j<=N&&Heap[j]>Heap[i]){
            printf("Not Heap\n");
            return;
        }
        j=2*i+1;
        if(j<=N&&Heap[j]>Heap[i]){
            printf("Not Heap\n");
            return;
        }
    }
    printf("Max Heap\n");
}

void Check2(){//Min;
    int i,j;
    for(i=N/2;i>=1;i--){
        j=2*i;
        if(j<=N&&Heap[j]<Heap[i]){
            printf("Not Heap\n");
            return;
        }
        j=2*i+1;
        if(j<=N&&Heap[j]<Heap[i]){
            printf("Not Heap\n");
            return;
        }
    }
    printf("Min Heap\n");
}

void PostOrder(int root){
    if(root>N){
        return;
    }
    PostOrder(2*root);
    PostOrder(2*root+1);
    printf("%d",Heap[root]);
    seq++;
    if(seq==N){
        printf("\n");
    }else{
        printf(" ");
    }
}


void Init(){
    int i;
    seq=0;
    for(i=1;i<=N;i++){
        scanf("%d",&Heap[i]);
    }
    if(Heap[1]>Heap[2]){
        Check1();//Max
    }else{
        Check2();
    }
    PostOrder(1);
}

int main(){
    scanf("%d%d",&M,&N);
    while(M--){
        Init();
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值