Stars(树状数组)

http://acm.hdu.edu.cn/showproblem.php?pid=1541

思路:对于两个点i,j,若xi>=xj,且yi>=yj,点i才能升一个level,现在对于后面输入的点的y值肯定比前面输入的点的y值要来的大,那么比较x就好了,现在就回到跟前面一篇的思路差不多的地方了,只是这里要求的是对于每一个出现的点,他的level的确定取决于前面有多少个比他小的x的点的个数。

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6619    Accepted Submission(s): 2640


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 

Source
 
#include <cstdio>
#include <cstring>
int n;
int c[32010];
int ans[15010];
int x[15010];
int bit(int t){
    return t&(-t);
}
void update(int pos){
    while(pos<=32010){
        c[pos]++;
        pos+=bit(pos);
    }
}
int getsum(int pos){
    int ans=0;
    while(pos>0){
        ans+=c[pos];
        pos-=bit(pos);
    }
    return ans;
}
int main(){
    while(scanf("%d",&n)!=EOF){
        memset(c,0,sizeof(c));
        memset(ans,0,sizeof(ans));
        for(int i=0;i<n;i++){
            int y;
            scanf("%d%d",&x[i],&y);
            x[i]++;
            int k=getsum(x[i]);//k表示当前元素属于哪一个level的
            ans[k]++;
            update(x[i]);//出现的点的地方加一个1
        }
        for(int i=0;i<n;i++){
                printf("%d\n",ans[i]);
        }
    }
    return 0;
}

AC之路,我选择坚持~~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值