LightOJ 1058 Parallelogram Counting(数学)

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

Input starts with an integer T (≤ 15), denoting the number of test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

For each case, print the case number and the number of parallelograms that can be formed.

Sample Input

2

6

0 0

2 0

4 0

1 1

3 1

5 1

7

-2 -1

8 9

5 7

1 1

4 8

2 0

9 8

Sample Output

Case 1: 5

Case 2: 6

题意:给你n个点的坐标,求能构成的平行四边形的个数。平行四边形的对角线的中点肯定是重合的。所以把对角线中点求出来。排序,便利查找相等的个数,再排列组合。求出结果。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
	int x;
	int y;
}stu[1100],mid[1100000];
int cmp(node a,node b)
{	
	if(a.x!=b.x)
	return a.x<b.x;
	else
	return a.y<b.y;
}
int main()
{
	int t,n,i,j,cas=0;
	int cnt,ans,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d%d",&stu[i].x,&stu[i].y);
		k=0;
	for(i=1;i<n;i++)
		for(j=i+1;j<=n;j++)
		{
			mid[k].x=stu[i].x+stu[j].x;
			mid[k].y=stu[i].y+stu[j].y;
			k++;
		}
		sort(mid,mid+k,cmp);
		cnt=1;
		ans=0;
		for (i=0;i<k-1;i++)
		{
			if(mid[i].x==mid[i+1].x&&mid[i].y==mid[i+1].y)
			cnt++;
			else
			{
				ans=ans+(cnt*(cnt-1)/2);
				cnt=1;
			}
		}
	printf("Case %d: %d\n",++cas,ans);
	}
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值