POJ 1797 Heavy Transportation

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5


Sample Output
Scenario #1:
4
题意:有N组数据,每组数据有n个城市,m条路径(双向路径),输出城市1到达城市n,输出边的最小值,路径的最大值。
这道题和Frogger恰恰相反,只不过数据范围有点大,所以就用一种方法写了,还可以用最大生成树写,因为练习的是最短路,所以就用Dijkstra写了,以后再把其他解法写上吧。
#include <stdio.h>
#include <string.h>
#define min(x,y) ((x)<(y)?(x):(y))
int dis[1005];
int book[1005];
int e[1005][1005];
int init(int n) {
	for(int i = 1; i <= n; i++) {
		book[i] = 0;
		for(int j = 1; j <= n; j++) {
			e[i][j] = 0;//因为要找每条路径的最小权值,所以赋值为0 
		}
	}
}
int main() {
	int N;//N组数据
	int n, m;
	int Case = 1;
	int t1, t2, t3;
	scanf("%d", &N);
	while(N--) {
		scanf("%d %d", &n, &m);
		init(n);
		for(int i = 0; i < m; i++) {
			scanf("%d %d %d",&t1, &t2, &t3);
			e[t1][t2] = t3;
			e[t2][t1] = t3;
		}
		for(int i = 1; i <= n; i++) {
			dis[i] = e[1][i];
		}
		book[1] = 1;
		int mx, p;
		for(int i = 1; i <= n; i++) {
			mx = -1;
			for(int j = 1; j <= n; j++) {
				if(!book[j] && mx < dis[j]) {//找到最大的 
					mx = dis[j];
					p  = j;
				}
			}
			book[p] = 1;
			for(int k = 1; k <= n; k++) {
				if(book[k]) continue;
				if(dis[k] < min(dis[p], e[p][k]))
				dis[k] = min(dis[p], e[p][k]);
			}
		}
		printf("Scenario #%d:\n",Case++);
		printf("%d\n\n",dis[n]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值