逃离迷宫(bfs)

Problem:逃离迷宫

Description:
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input:
第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符’.‘表示该位置为空地,字符’*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。

Output:
每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input:

2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3

Sample Output:

no
yes

Language:C++

#include <iostream>
#include <cstring>
#include <queue>

using namespace std;

struct node
{
  int x;
  int y;
  int cnt;
}head,tail;

int m,n;
char s[101][101];
int k,x1,y1,x2,y2;
bool vis[101][101];
int step[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

void bfs()
{
  queue<node>q;
  head.x=x1;
  head.y=y1;
  head.cnt=-1;
  memset(vis,0,sizeof(vis));

  q.push(head);
  while(!q.empty())
  {
    head=q.front();
    q.pop();

    if(head.x==x2&&head.y==y2&&head.cnt<=k)
    {
      cout<<"yes"<<endl;
      return;
    }

    tail.cnt=head.cnt+1;
    for(int i=0;i<4;i++)
    {
      int tx=head.x+step[i][0];
      int ty=head.y+step[i][1];
      while(tx>=1&&tx<=m&&ty>=1&&ty<=n&&s[tx][ty]=='.')
      {
        if(!vis[tx][ty])
        {
          vis[tx][ty]=1;
          tail.x=tx;
          tail.y=ty;
          q.push(tail);
        }
        tx+=step[i][0];
        ty+=step[i][1];
      }
    }
  }
  cout<<"no"<<endl;
}

int main()
{
  int t;
  cin>>t;
  while(t--)
  {
    cin>>m>>n;
    for(int i=1;i<=m;i++)
    {
      for(int j=1;j<=n;j++) cin>>s[i][j];
    }
    cin>>k>>y1>>x1>>y2>>x2;

    bfs();
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值