逃离迷宫(BFS)

逃离迷宫(BFS)

Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,   第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符’.‘表示该位置为空地,字符’*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x[sub]1[/sub], y[sub]1[/sub], x[sub]2[/sub], y[sub]2[/sub] (1 ≤ k ≤ 10, 1 ≤ x[sub]1[/sub], x[sub]2[/sub] ≤ n, 1 ≤ y[sub]1[/sub], y[sub]2[/sub] ≤ m),其中k表示gloria最多能转的弯数,(x[sub]1[/sub], y[sub]1[/sub]), (x[sub]2[/sub], y[sub]2[/sub])表示两个位置,其中x[sub]1[/sub],x[sub]2[/sub]对应列,y[sub]1[/sub], y[sub]2[/sub]对应行。

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input
2
5 5
…**
*..



1 1 1 1 3
5 5

*.
*.


*…
2 1 1 1 3

Sample Output
no
yes

本题使用BFS通过,BFS+单方向行走。DFS未尝试,但根据前人的博客,似乎过不去,会TLE。
思路来源:https://blog.csdn.net/qq_40626497/article/details/81149915

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;

char map[101][101];  //记录地图
int visit[101][101];  //记录是否走过该点
int n, m;  //记录最大行列
int k, x1, y1, x2, y2; //记录最大拐角以及始末点
int t;  //记录运行次数
int dir[4][2] = { {0,1},{0,-1},{1,0},{-1,0} }; //右左上下四个方向
int flag;  //标记是否满足条件。即:步数<=k;从起始点走到终点

struct node   //存放临时(x,y)与步数k
{
	int x, y, k;
};

int check(int x, int y)  //检查该点是否在地图内并且无障碍
{
	if (x >= 0 && x < n && y >= 0 && y < m&&map[x][y]=='.')
		return 1;
	return 0;
}

void bfs()
{
	node now, next, temp;  //需要设置当前状态,下一个状态和一个中转状态(若不用中转状态会导致错误,不知为何)
	queue<node> que;
	now.x = x1;
	now.y = y1;
	now.k = -1;
	visit[x1][y1] = 1;
	que.push(now);
	while (que.size())
	{
		now = que.front(); que.pop();
		if (now.x == x2 && now.y == y2 && now.k <= k)
		{
			flag = 1;
			return;
		}
		for (int i = 0; i < 4; i++)
		{
			next.x = now.x + dir[i][0];
			next.y = now.y + dir[i][1];
			while (check(next.x, next.y))  //这里的核心算法是往一个方向走。
			{
				if (!visit[next.x][next.y])
				{
					next.k = now.k + 1;
					visit[next.x][next.y] = 1;
					que.push(next);
				}
				temp.x = next.x + dir[i][0];
				temp.y = next.y + dir[i][1];
				next = temp;
			}
		}
	}
}

int main()
{
	cin >> t;
	while (t--)
	{
		cin >> n >> m;
		for (int i = 0; i < n; i++)
			for (int j = 0; j < m; j++)
				cin >> map[i][j];
		memset(visit, 0, sizeof(visit));
		cin >> k >> y1 >> x1 >> y2 >> x2;
		x1--;y1--;x2--;y2--;
		flag = 0;
		bfs();
		if (flag)
			cout << "yes" << endl;
		else
			cout << "no" << endl;
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值