Fliptile(dfs+状态压缩)

Problem:Fliptile

Description:
Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.
As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.
Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input:
Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output:
Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input:

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output:

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Language:C++

#include <iostream>
#include <cstring>
#define INF 0x3f3f3f3f

using namespace std;
 
int M,N;
int square[20][20],res[20][20],final_res[20][20];
int step[5][2]={{0,0},{0,1},{0,-1},{1,0},{-1,0}};
 
int check(int x,int y)//查询(x,y)的颜色
{       
  int this_flip=square[x][y];
 
  for(int i=0;i<5;i++)
  {
    int xi=x+step[i][0];
    int yi=y+step[i][1];
 
    if(xi<1||xi>M||yi<1||yi>N)  continue;
    this_flip+=res[xi][yi];
  }
  return this_flip%2;
}

int dfs()
{
  for(int i=2;i<=M;i++)//求出从第二行至第M-1行的翻法
  {
    for(int j=1;j<=N;j++)
    {
      if(check(i-1,j))  res[i][j]=1;//如果格子上方是黑色地砖,则必须翻转这个格子
    }
  }
            
  for(int j=1;j<=N;j++)//判断第M行是否全白
  {
    if(check(M,j))  return -1;//无解
  }     
        
  int total_flip=0;//统计翻转次数
  for(int i=1;i<=M;i++)
  {
    for(int j=1;j<=N;j++)  total_flip+=res[i][j];
  }     
  return total_flip;
}
 
int main()
{
  while(cin>>M>>N)
  {
    for(int i=1;i<=M;i++)
    {
      for(int j=1;j<=N;j++)  cin>>square[i][j];
    }
      
    bool flag=false;
    int pre_flip=INF;
    for(int i=0;i<(1<<N);i++)//按照字典序枚举第一行的不同翻法
    {       
      memset(res,0,sizeof(res));
 
      for(int j=1;j<=N;j++)  res[1][N-j+1]=i>>(j-1)&1;//将其中一种可能的翻法保存

      int now_flip=dfs();
      if(now_flip>=0&&now_flip<pre_flip)
      {        
        flag=true;
        pre_flip=now_flip;
        memcpy(final_res,res,sizeof(res));
      }
    }

    if(flag)
    {
      for(int i=1;i<=M;i++)
      {
        for(int j=1;j<=N;j++)  cout<<final_res[i][j]<<(j==N ? '\n':' ');
      }
    }
    else  cout<<"IMPOSSIBLE"<<endl;   
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值