Battle City
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 8386 | Accepted: 2799 |
Description
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).
Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).
Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
Input
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
Sample Input
3 4 YBEB EERE SSTE 0 0
Sample Output
8
题意很简单,看了一段时间才会,其实因为遇到B需要多加一个时间单位,这时候就要
用到优先队列
<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
char map[310][310];
int vis[310][310];//标记是否已经走过
int dx[4]={1,-1,0,0};
int dy[4]={0,0,1,-1};
struct node
{
int x;
int y;
int temp;
};
bool operator < (node a,node b)//优先队列,按照temp从小到大
{
return a.temp>b.temp;//步数按照从小到大输出
}
int n,m,x,y;
int judge(int a,int b)
{
if(a<1||a>m||b<1||b>n||map[a][b]=='S'||map[a][b]=='R'||vis[a][b])
return 1;
return 0;
}
void bfs(int sx,int sy)
{
priority_queue<node>que;
node s;
s.x=sx;s.y=sy;
s.temp=0;
vis[sx][sy]=1;//表示已经走过
que.push(s);
while(!que.empty())
{
node now;
now=que.top();
que.pop();
//printf("%d %d %d\n",now.x,now.y,now.temp);
if(map[now.x][now.y]=='T')
{
printf("%d\n",now.temp);
return ;
}
for(int i=0;i<4;++i)
{
node end;
end.x=now.x+dx[i];
end.y=now.y+dy[i];
if(judge(end.x,end.y))
continue;
vis[end.x][end.y]=1;
end.temp=now.temp+1;
if(map[end.x][end.y]=='B')
end.temp++;
que.push(end);
}
}
printf("-1\n");
return ;
}
int main()
{
while(scanf("%d%d",&m,&n)!=EOF&&m!=0||n!=0)
{
int i,j;
memset(vis,0,sizeof(vis));
for(i=1;i<=m;++i)
{
scanf("%s",map[i]+1);
for(j=1;j<=n;++j)
{
if(map[i][j]=='Y')
{
x=i;y=j;//出发的坐标
}
}
}
bfs(x,y);
}
return 0;
} </span>