北京大学程序设计MOOC实习之魔兽世界(二)之装备

这次作业是在第一次的基础上完成的,主要要求是完成五种武士的封装。这五种武士的特性(相应类的成员变量)不大相同,但可以从同一个基类派生。随着时间变化,生成相应的武士,并输出相关信息。

描述
魔兽世界的西面是红魔军的司令部,东面是蓝魔军的司令部。两个司令部之间是依次排列的若干城市。

红司令部,City 1,City 2,……,City n,蓝司令部

两军的司令部都会制造武士。武士一共有 dragon 、ninja、iceman、lion、wolf 五种。每种武士都有编号、生命值这两种属性。
有的武士可以拥有武器。武器有三种,sword, bomb,和arrow,编号分别为0,1,2。
双方的武士编号都是从1开始计算。红方制造出来的第 n 个武士,编号就是n。同样,蓝方制造出来的第 n 个武士,编号也是n。

不同的武士有不同的特点。
dragon 可以拥有一件武器。编号为n的dragon降生时即获得编号为 n%3 的武器。dragon还有“士气”这个属性,是个浮点数,其值为它降生后其司令部剩余生命元的数量除以造dragon所需的生命元数量。

ninja可以拥有两件武器。编号为n的ninja降生时即获得编号为 n%3 和 (n+1)%3的武器。

iceman有一件武器。编号为n的iceman降生时即获得编号为 n%3 的武器。
lion 有“忠诚度”这个属性,其值等于它降生后其司令部剩余生命元的数目。

wolf没特点。

请注意,在以后的题目里,武士的士气,生命值,忠诚度在其生存期间都可能发生变化,都有作用,武士手中的武器随着使用攻击力也会发生变化。

武士在刚降生的时候有一个生命值。

在每个整点,双方的司令部中各有一个武士降生。

红方司令部按照 iceman、lion、wolf、ninja、dragon 的顺序循环制造武士。

蓝方司令部按照 lion、dragon、ninja、iceman、wolf 的顺序循环制造武士。

制造武士需要生命元。

制造一个初始生命值为 m 的武士,司令部中的生命元就要减少 m 个。

如果司令部中的生命元不足以制造某个按顺序应该制造的武士,那么司令部就试图制造下一个。如果所有武士都不能制造了,则司令部停止制造武士。
给定一个时间,和双方司令部的初始生命元数目,要求你将从0点0分开始到双方司令部停止制造武士为止的所有事件按顺序输出。
一共有两种事件,其对应的输出样例如下:

  1. 武士降生
    输出样例: 004 blue lion 5 born with strength 5,2 lion in red headquarter
    表示在 4点整,编号为5的蓝魔lion武士降生,它降生时生命值为5,降生后蓝魔司令部里共有2个lion武士。(为简单起见,不考虑单词的复数形式)注意,每制造出一个新的武士,都要输出此时司令部里共有多少个该种武士。

如果造出的是dragon,那么还要输出一行,例:
It has a arrow,and it’s morale is 23.34
表示该dragon降生时得到了arrow,其士气是23.34(为简单起见,本题中arrow前面的冠词用a,不用an,士气精确到小数点后面2位,四舍五入)

如果造出的是ninja,那么还要输出一行,例:
It has a bomb and a arrow
表示该ninja降生时得到了bomb和arrow。

如果造出的是iceman,那么还要输出一行,例:
It has a sword
表示该iceman降生时得到了sword。

如果造出的是lion,那么还要输出一行,例:
It’s loyalty is 24
表示该lion降生时的忠诚度是24。

  1. 司令部停止制造武士
    输出样例: 010 red headquarter stops making warriors
    表示在 10点整,红方司令部停止制造武士

输出事件时:

首先按时间顺序输出;

同一时间发生的事件,先输出红司令部的,再输出蓝司令部的。

输入
第一行是一个整数,代表测试数据组数。

每组测试数据共两行。

第一行,一个整数M。其含义为: 每个司令部一开始都有M个生命元( 1 <= M <= 10000)

第二行:五个整数,依次是 dragon 、ninja、iceman、lion、wolf 的初始生命值。它们都大于0小于等于10000

输出
对每组测试数据,要求输出从0时0分开始,到双方司令部都停止制造武士为止的所有事件。
对每组测试数据,首先输出“Case:n" n是测试数据的编号,从1开始
接下来按恰当的顺序和格式输出所有事件。每个事件都以事件发生的时间开头,时间以小时为单位,有三位。

样例输入

1
20
3 4 5 6 7

样例输出

Case:1
000 red iceman 1 born with strength 5,1 iceman in red headquarter
It has a bomb
000 blue lion 1 born with strength 6,1 lion in blue headquarter
It's loyalty is 14
001 red lion 2 born with strength 6,1 lion in red headquarter
It's loyalty is 9
001 blue dragon 2 born with strength 3,1 dragon in blue headquarter
It has a arrow,and it's morale is 3.67
002 red wolf 3 born with strength 7,1 wolf in red headquarter
002 blue ninja 3 born with strength 4,1 ninja in blue headquarter
It has a sword and a bomb
003 red headquarter stops making warriors
003 blue iceman 4 born with strength 5,1 iceman in blue headquarter
It has a bomb
004 blue headquarter stops making warriors

思路:
游戏双方各有一司令部,相应的即为head类的两个对象。每个head对象内部produce函数分别完成武士生成。构建武士对象时采用工厂方法,私有make_warrior方法根据武士名称新建相应武士对象并返回指针。

另外,输出结果要求小数点精度为两位。这需要cout的fixed、setprecision(2)两种方法同时使用。单独setprecision可以设定总体精度。

代码:

#include<iostream>
#include<iomanip>
#include<algorithm>
#include<string>
using namespace std;

const string weapon = {'sword','bomb','arrow'};

class warrior{
	public:
		int num;
		int life;
		warrior(int n,int l):num(n),life(l){
		}
		virtual void show() {;
		} ;
}; 

class dragon:public warrior{
	public:
		int wepn;
		float morale; //元气 
		dragon(int n,int l,float mor):warrior(n,l),morale(mor){
			wepn = n%3;
			show();
		}
		void show(){
			cout<<"It has a "+ weapon[wepn] + ",and it's morale is "<<fixed<<setprecision(2)<<morale<<endl; 
		}
};

class ninja:
	public warrior{
		public:
			int wepn[2];
			ninja(int n,int l):warrior(n,l){
				wepn[0] = n%3;
				wepn[1] = (n+1)%3;
				show();
			} 
			
			void show(){
				cout<<"It has a "+ weapon[wepn[0]]<<" and a "+ weapon[wepn[1]]<<endl;
			}
};
	
class iceman:
	public warrior{
		public:
			int wepn;
			iceman(int n,int l):warrior(n,l){
				wepn = n%3;
				show(); 
			}
			
			void show(){
				cout<<"It has a "+ weapon[wepn]<<endl;
			} 
	};
	
	class lion:
		public warrior{
			public:
				int loyalty;
				lion(int n,int l,int loyal):warrior(n,l){
					loyalty = loyal;
					show();
				}
				
				void show(){
					cout<<"It's loyalty is "<<loyalty<<endl; 
				}
		};

class wolf:
	public warrior{
		public:
			wolf(int n,int l):warrior(n,l){
			}
			void show(){
			}
	};
	
class head{
	private:
		string head_colour;
		string sort[5];
		int num[5];  
		int life[5];
		int total_life;
		int time; 
		bool runout; 
		int ind; 
		int count;
	public:
		head(string _head_co, string _sort[],int _life[],int _t_life){
			fill_n(num,5,0);
			time = 0;
			runout = 0;
			ind = 0;
			count = 0;
			total_life = t_life;
			head_colour = head_co;
			copy(_sort, _sort+5, sort);
			copy(_life,_life+5,life);
		}
		
		bool is_stoped(){
			return runout;
		}
		
		void produce();
	private:
		warrior* make_warrior(int, int);
};

warrior* head::make_warrior(int find,int left_life){
	if(sort[ind]=="dragon"){
		return new dragon(count,life[ind],float(left_life)/life[ind]);
	}else if(sort[ind]=="ninja"){
		return new ninja(count, life[ind]);
	}else if(sort[ind]=="iceman"){
		return new iceman(count,life[ind]);
	}else if(sort[ind]=="lion"){
		return new lion(count,life[ind],left_life);
	}else if(sort[ind]=="wolf"){
		return new wolf(count,life[ind]);
	}
}

void head::produce(){
	int real_ind = ind % 5;
	if(runout) return;
	int i = 0;
	for(;total_life<life[(real_ind+i)%5] && i<5;++i);
	
	if(i==5){
		cout<<setfill("0")<<setw(3)<<count<<" "<<head_colour<<"headquarter stops making warriors"<<endl;
		runout = true;
		return;
	}
	
	real_ind = (real_ind + i) % 5;
	if(total_life>=life[real_ind]){
		total_life -= life[real_ind];
		num[real_ind] += 1;
		count += 1;
		cout<<setfill('0')<<setw(3)<<count - 1<<" "<<head_colour<<" "<<sort[real_ind]<<" "<<
		warrior* wp = make_warrior(real_ind,total_life);
		ind = ind + i + 1;
	}
	return;
}

int main(){
	int n_case;
	cin>>n_case;
	int life[n_case][5];
	int n_life[n_case];
	
	for(int i = 0;i<n_case;++i){
		cin>>n_life[i];
		for(int j = 0;j<5;++j){
			cin>>lifes[i][j];
		} 
	}
	
	for(int m = 0;m<n_case;++m){
		int life[5];
		for(int t = 0;t<5;++t){
			life[t] = lifes[m][t];
		}
		cout<<"Case: "<<m+1<<endl;
		string red_sort[] = {"iceman","lion","wolf","ninja","dragon"};
		string blue_sort[] = {"loin","dragon","ninja","iceman","wolf"};
		
		int red_life[] = {life[2],life[3],life[4],life[1],life[0]};
		int blue_life[] = {life[3],life[0],life[1],life[2],life[4]};
		
		head red("red",red_sort,red_life,n_life[m]);
		head blue("blue",blue_sort,blue_life,n_life[m]);
		
		while(!red.is_stoped() || !blue.is_stoped()){
			if(!red.is_stoped()) red.produce();
			if(!blue.is_stoped()) blue.produce(); 
		} 
	}
	return 0; 
}
	
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值