PAT甲级 1027. Colors in Mars (20)

1027. Colors in Mars (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

#include <iostream>
#include <algorithm>
#include<string.h>
#include<cstdio>
using namespace std;


void trans(int n)
{
    char s[3];
    int cnt=0;
    while(n!=0)
    {
        s[cnt++]=n%13;
        if(s[cnt-1]<10) s[cnt-1]+='0';
        else s[cnt-1]=s[cnt-1]-10+'A';
        n/=13;
    }
    if(cnt==0)
    {
        s[0]='0';
        s[1]='0';
    }
    if(cnt==1)
    {
        s[1]='0';
    }
    cout<<s[1]<<s[0];
}

int main()
{
    int n1,n2,n3;
    cin>>n1>>n2>>n3;
    cout<<"#";
    trans(n1);
    trans(n2);
    trans(n3);
    cout<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值