【PAT】1027. Colors in Mars (20)

题目描述

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

翻译:在火星上的人们他们电脑中保存颜色的方式与地球人很相似。那就是,一个6位数字代表一个颜色,前两位是红色,中间两位是绿色,最后两位是蓝色。唯一的区别为他们用13进制 (0-9 and A-C) 而不是16进制。现在给你一个用三个数字表示的颜色 (每个都在0和168之间),你需要输出火星RGB值。

INPUT FORMAT

Each input file contains one test case which occupies a line containing the three decimal color values.

翻译:每个输入文件包含一组测试数据,包括一行3个表示颜色的十进制数。

OUTPUT FORMAT

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

翻译:对于每组测试数据,你需要按照以下格式输出火星RGB数值。首先输出一个“#”,接下来跟着一个6位数字,所有英文字母都要大写。如果一个颜色只有一位,你需要在前面补0。


Sample Input

15 43 71

Sample Output

#123456


解题思路

水题,直接按13进制保存到数组,判断数值是否大于10输出即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int a[6];
int main(){
    int C[3];
    scanf("%d%d%d",&C[0],&C[1],&C[2]); 
    for(int i=0;i<3;i++){
        if(C[i]/13)a[2*i]=C[i]/13;
        a[2*i+1]=C[i]%13;
    }
    printf("#");
    for(int i=0;i<6;i++){
        if(a[i]==10)printf("A");
        else if(a[i]==11)printf("B");
        else if(a[i]==12)printf("C");
        else printf("%d",a[i]);
    }   
    printf("\n");
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值